This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: fix middle-end/16417


On Monday 20 December 2004 00:18, James A. Morrison wrote:
> 
> Florian Weimer <fw@deneb.enyo.de> writes:
> 
> > * Richard Henderson:
> > 
> > > Because they still havn't fixed the build problems.  It chooses
> > > the installed gnatbind rather than the stage1, which means stage2
> > > build always fails unless you have the *current* version installed.
> > 
> > I can bootstrap with a gnatbind version that is definitely not
> > compatible with the version which is being built.
> > 
> > It's been reported, though, that if you set a --prefix which already
> > contains a GNAT installation, this one has to be compatible (but this
> > is the "installed gnatbind" only by accident).  This is not the common
> > case during GCC development, I presume, ...
> 
>  This is exactly what I do.  It seems I've been rather fortunate not to have
> to deal with more than one branch at a time.

Maybe you install a new version fairly often?  The only times I've seen problems
is when the last version installed to --prefix was old (> 1 month?) compared
to the version being bootstrapped.  Both versions being CVS snapshots by the way.

Ciao,

Duncan.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]