This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: bootstrap failure on alpha and solaris Re: [RFA] automake mass update, 2 of 2

Thanks for looking into this.

I've fought with this issue off and on in the upstream distribution,
though I don't understand the detailed considerations here.

It used to be (and still is?) that gcc encouraged the convention that
preprocessed assembly files ended in .S and nonpreprocessed files ended in .s.
This has always struck me as a clean convention.  And I think it's necessary
to have such a convention.  The only difficulty in the past has been
that it wasn't adhered to by non-gcc tool chains.

In my view, I would like to fix this in a way that at least moves us no
further away from following this convention.  The sparc and darwin files
are different kinds of source, and shouldn't have the same suffix.

I'm also not sure that renaming things from ...mach_dep... to ...arch_dep...
is an improvement.  In the gcc context that makes sense.  But for the upstream
distribution, the dependency is as much on the tool chain as on the


> -----Original Message-----
> From: 
> []On Behalf Of
> Andreas Tobler
> Sent: Thursday, June 17, 2004 12:48 AM
> To: Paolo Bonzini
> Cc: Paolo Bonzini;;; Richard
> Henderson
> Subject: Re: bootstrap failure on alpha and solaris Re: [RFA] automake
> mass update, 2 of 2
> >-- Original Message --
> >> The only thing so far which works on darwin (.s) and 
> solaris (.S) is
> >> this. I'm not very happy with, not so elegant, code duplication :)
> >> Maybe there is a more elegant, or the right (tm) way?
> >
> >Hmmm... maybe renaming the two .S files to .s?!?
> >
> >Can you test it?
> That was the first step I did, on solaris I renamed it to 
> sparc_arch_dep.s
> and built it. Seemed to work.
> Don't know about alpha?
> Andreas

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]