This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Configure problem


On Tue, May 18, 2004 at 11:16:58PM +0200, Zdenek Dvorak wrote:
> Hello,
> 
> > On Thu, May 13, 2004 at 07:43:46PM -0700, Jim Wilson wrote:
> > > Zdenek Dvorak wrote:
> > > >pwd: /abuild/gcc-test/gcc/objdir/x86_64-unknown-linux-gnu/libobjc
> > > >Running configure in multilib subdir 32
> > > >pwd: /abuild/gcc-test/gcc/objdir/x86_64-unknown-linux-gnu
> > > >configure: loading cache ./config.cache
> > > >configure: error: `target_alias' was not set in the previous run
> > > 
> > > I can reproduce this even without multilibs on x86-linux
> > >   cvs update
> > >   mkdir objdir
> > >   cd objdir
> > >   ../configure
> > >   make
> > >   touch ../gcc/libobjc/Makefile.in
> > >   make
> > 
> > How?  When I do this, config.status is rerun, but configure isn't. 
> > Both rules which change or rerun configure remove config.cache, and
> > have since the first import of libobjc.  So I can't reproduce this in
> > libobjc by touching configure either.
> 
> on x86 this does not work for me, either.  On x86_64, this worked for
> me.

With or without multilibs?  It didn't work for me on x86_64
--disable-multilib.

-- 
Daniel Jacobowitz


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]