This is the mail archive of the
mailing list for the GCC project.
Re: Rename tree_ann to tree_ann_t
- From: Diego Novillo <dnovillo at redhat dot com>
- To: Steven Bosscher <stevenb at suse dot de>
- Cc: "gcc-patches at gcc dot gnu dot org" <gcc-patches at gcc dot gnu dot org>, Daniel Berlin <dberlin at dberlin dot org>
- Date: Mon, 17 May 2004 16:20:30 -0400
- Subject: Re: Rename tree_ann to tree_ann_t
- Organization: Red Hat Canada
- References: <email@example.com>
On Sun, 2004-05-16 at 06:32, Steven Bosscher wrote:
> But the generic tree_ann is a type name, where the other kinds
> of tree annotations have a *_t suffix. This patch renames
> tree_ann to tree_ann_t, and adds a few functions to create and
> access the generic tree_ann_t annotations.
Why do you want to create a generic tree_ann_t object? What annotations
are you trying to add? It'd be better to sub-type them like we did for
I agree with the name change for tree_ann, but I don't think we want to
create objects of tree_ann_t. There'd be no way of checking that they
are attached to the right trees.