This is the mail archive of the
mailing list for the GCC project.
Re: [patch] Rename default_strict_argument_naming() tohook_bool_CUMULATIVE_ARGS_false().
- From: Kazu Hirata <kazu at cs dot umass dot edu>
- To: graham dot stott at btinternet dot com
- Cc: gcc-patches at gcc dot gnu dot org
- Date: Sun, 01 Feb 2004 11:39:29 -0500 (EST)
- Subject: Re: [patch] Rename default_strict_argument_naming() tohook_bool_CUMULATIVE_ARGS_false().
- References: <138010.1075618500125.JavaMail.email@example.com>
> The uppercase CUMULATIVE_ARGS in the hook names looks very odd
> to me and probably goes against gcc coding conventions.
The GNU Coding Standards say
Please use underscores to separate words in a name, so that the
Emacs word commands can be useful within them. Stick to lower case;
reserve upper case for macros and enum constants, and for
name-prefixes that follow a uniform convention.
> I don't have immediate access to any machine with GCC sources
> at present so can't check if we any precedents in this area.
The only reason for using upper case is that there is already
hook_bool_CUMULATIVE_ARGS_true, so I made the ..._false version by
I sort of want to keep the original type name, CUMULATIVE_ARGS, as is
in the function name. (Well, there is another question whether
CUMULATIVE_ARGS should be in upper case when it only corresponds to a
struct type or int; we could simply typedef cumulative_args instead of