This is the mail archive of the
mailing list for the GCC project.
Re: [C++ patch] final? unit-at-a-time patch
> On Sat, 2003-06-21 at 15:31, Jan Hubicka wrote:
> > Hi,
> > this patch finally implements unit-at-a-time mode in C++. I
> > regtested/bootstrapped it in both unit-at-a-time and non-unit-at-a-time mode.
> > In unit-at-a-time mode it still fails with testcase pretty1.c/pretty2.c, but I
> > can trigger same failure by deferring the functions via inline keyword, so it
> > is latent bug I will try to fix shortly too.
> That needs to get fixed *before* we put in the unit-at-a-time stuff.
Actually I noticed that these failures are happening for me in the other
tree too, so perhaps it is some desynchronization (or temporary problem
of the tree I am using for testing). Lets walk down the road with
other patches that this patch depends on and lets see whether it
> really_expand_body needs a better name. :-) Probably "expand_body"
> should be renamed to expand_or_defer_fn and "really_expand_body" should
> be renamed to "expand_body".
I am currently using this same naming for c/objC, perhaps we can rename
it all at once via simple minded patch afterwards..
> Other than that, this patch looks OK to me.
Very cool! Thanks!
> Mark Mitchell
> CodeSourcery, LLC