This is the mail archive of the
mailing list for the GCC project.
Re: [patch] alias.c: Replace "return NULL_RTX" with "return 0".
On Fri, 13 Jun 2003 04:55:41 +1000, Fergus Henderson <email@example.com> wrote:
> On 12-Jun-2003, Zack Weinberg <firstname.lastname@example.org> wrote:
>> Fergus Henderson <email@example.com> writes:
>> > On 12-Jun-2003, Kazu Hirata <firstname.lastname@example.org> wrote:
>> >> Attached is a patch to replace "return NULL_RTX" with "return 0".
>> > I think it would be better style to replace NULL_RTX with NULL
>> > rather than with 0.
>> GCC sources prefer 0 to NULL for a generic null pointer.
> GCC was once written in K&R C, but times change :-)
I prefer NULL to 0. It is both more readable and more reliable in the
presence of varargs.