This is the mail archive of the
mailing list for the GCC project.
Re: Recent change to mips_output_move
> Ah, OK.
> I personally find "move", "li" and "dli" more readable than things like
> "or $4,$5,$0" and "addi $4,$0,0x1000". Any chance of keeping them the
> way they are? After all, "move" always expands to a single insn, and we
> already restrict ourselves to single-insn "li"s and "dli"s.
I don't think that'll be much of a problem. I suppose then we should
change the .set nomacro warning to ignore those 3, since, really they're
just aliases for readability.
(Really should commit move_register to using or though...)
Eric Christopher <firstname.lastname@example.org>