This is the mail archive of the
mailing list for the GCC project.
Re: C++ PATCH to decl.c: Factor debug code
On 30 May 2003 19:28:21 +0200, Gabriel Dos Reis <email@example.com> wrote:
> Jason Merrill <firstname.lastname@example.org> writes:
> | On 30 May 2003 03:12:26 +0200, Gabriel Dos Reis <email@example.com> wrote:
> | > OK for mainline?
> | Mostly.
> | > OK for branch?
> | What branch, and why?
> Because a name-lookup performance patch depends on it.
I assume you're talking about the 3.3 branch?
I don't think a name-lookup performance patch would be acceptable for the
3.3 branch, either. Better performance is great, but we need to be
conservative on release branches.
> I've being trying to have a consistent naming, any thing starting with
> cxx_scope deals exclusively with scopes., which explains cxx_scope_make.
> I think that naming scheme is fairly widespread.
I suspected that was where the name came from. Let's go with
make_cxx_scope for that one.