This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: C++ PATCH to decl.c: Factor debug code


Benjamin Kosnik <bkoz@redhat.com> writes:

| > These two names sound odd to me; I'd say cxx_make_scope or make_cxx_scope,
| > and initial_push_namespace_scope.  Also, the latter needs a comment.
| 
| Huh. I'd thought the same thing when I read this patch.
| 
| ... or maybe push_initial_namespace_scope and make_cxx_scope? Most
| functions seem to be named with the active verb as the first bit, at
| least that is the active convention that I'm pushing in the runtime.

I'll incorporate those suggestions.

I still need to know whether it is OK for branch.  This patch has been
triggered by the name-lookup performance   work.

-- Gaby


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]