This is the mail archive of the
mailing list for the GCC project.
Re: C++ PATCH to decl.c: Factor debug code
- From: Benjamin Kosnik <bkoz at redhat dot com>
- To: gcc-patches at gcc dot gnu dot org
- Cc: gdr at integrable-solutions dot net, jason at redhat dot com
- Date: Fri, 30 May 2003 12:28:12 -0500
- Subject: Re: C++ PATCH to decl.c: Factor debug code
> These two names sound odd to me; I'd say cxx_make_scope or make_cxx_scope,
> and initial_push_namespace_scope. Also, the latter needs a comment.
Huh. I'd thought the same thing when I read this patch.
... or maybe push_initial_namespace_scope and make_cxx_scope? Most
functions seem to be named with the active verb as the first bit, at
least that is the active convention that I'm pushing in the runtime.