This is the mail archive of the
mailing list for the GCC project.
Re: C++ PATCH to decl.c: Factor debug code
Jason Merrill <email@example.com> writes:
| On 30 May 2003 03:12:26 +0200, Gabriel Dos Reis <firstname.lastname@example.org> wrote:
| > OK for mainline?
| > OK for branch?
| What branch, and why?
Because a name-lookup performance patch depends on it.
| > (cxx_scope_make): New function.
| > (cxx_original_namespace_scope_push): New function.
| These two names sound odd to me; I'd say cxx_make_scope or make_cxx_scope,
| and initial_push_namespace_scope.
I've being trying to have a consistent naming, any thing starting with
cxx_scope deals exclusively with scopes., which explains cxx_scope_make.
I think that naming scheme is fairly widespread.
I was not particularly proud of cxx_original_namespace_scope_push.
| Also, the latter needs a comment.