This is the mail archive of the
mailing list for the GCC project.
Re: [PATCH RS6000] adding an unsigned SI and a DI together and subtracting an unsigned SI from an DI
- From: Richard Henderson <rth at redhat dot com>
- To: David Edelsohn <dje at watson dot ibm dot com>
- Cc: Andrew Pinski <pinskia at physics dot uc dot edu>, gcc-patches at gcc dot gnu dot org
- Date: Wed, 14 May 2003 10:09:28 -0700
- Subject: Re: [PATCH RS6000] adding an unsigned SI and a DI together and subtracting an unsigned SI from an DI
- References: <20030514075047.GB16863@redhat.com> <200305141655.MAA27508@makai.watson.ibm.com>
On Wed, May 14, 2003 at 12:55:22PM -0400, David Edelsohn wrote:
> What is the current recommendation with regard to use of
> gen_lowpart/gen_highpart vs operand_subword vs simplify_gen_subreg?
I kinda always liked lowpart/highpart myself. *shrug*
Incidentally, you bring up a good point -- I believe that
lowpart/highpart *are* endian sensative, and so the code
in that patch to switch based on endianness is wrong.