This is the mail archive of the
mailing list for the GCC project.
Re: PATCH for [ARM] subsequent use of plus and minus operators couldbe improved
- From: Gábor Lóki <alga at rgai dot hu>
- To: Zack Weinberg <zack at codesourcery dot com>
- Cc: Richard dot Earnshaw at arm dot com, gcc-patches <gcc-patches at gcc dot gnu dot org>
- Date: Tue, 06 May 2003 17:06:56 +0200
- Subject: Re: PATCH for [ARM] subsequent use of plus and minus operators couldbe improved
- References: <200304071029.h37ATks28444@pc960.cambridge.arm.com> <3E9D4934.email@example.com> <firstname.lastname@example.org>
Zack Weinberg wrote:
> Gábor Lóki <email@example.com> writes:
>>Richard Earnshaw wrote:
>> > First of all, please read the documents on contributing to GCC and pay
>> > particular attention to the coding standards sections. Patches can only
>> > be accepted if they conform to these standards.
>>Ok. I am done with the code forming.
> This is looking good. A couple of style nitpicks:
Thanks the suggestions. I am done with them.
>>I examined the reload_cse_move2add candidate again, but as I saw it
>>first, this function tries to transform move instruction into
>>add. This isn't what I'd like to do, and no other reload_cse passes do
>>the same thing. These were the reasons why I created a new function.
>>You are right. There is no reason for another scan on the RTL. So I
>>merged my code with reload_cse_move2add. You can see in the attached
> Perhaps it is appropriate to rename reload_cse_move2add - call it
> "postreload_combine" or "postreload_simplify_rtx" or something like
> that. Other people can make better suggestions than me.
You are right. It ought to be renamed. "postreload_simplify_rtx" sounds good.