This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] add __amd64__ predefined symbols


> Jan Hubicka <jh@suse.cz> writes:
> 
> >> On Sun, Apr 27, 2003 at 12:15:56AM +0200, Jan Hubicka wrote:
> >> > > >  	  builtin_assert ("machine=x86_64");			\
> >> ...
> >> > The naming change is bit problematic.  We still have only one choice to
> >> > define for "machine" ...
> >> 
> >> Um, no, assertions are pair associations, not assignments.
> >> You can have more than one.
> >
> > As Zack mentioned the assertions are obsoletted now, so Andreas is
> > testing whether removing the assertion breaks something.  Would that be
> > OK for you? (done for both 3.3.1 and mainline)
> 
> I didn't notice directly any problems, so it seems to be fine,
OK, I will remove the assertion in mainline today and 3.3 once Mark
unfreezes the tree.

Honza
> 
> Andreas
> -- 
>  Andreas Jaeger
>   SuSE Labs aj@suse.de
>    private aj@arthur.inka.de
>     http://www.suse.de/~aj


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]