This is the mail archive of the
mailing list for the GCC project.
Re: [PATCH] add __amd64__ predefined symbols
- From: Andreas Jaeger <aj at suse dot de>
- To: Jan Hubicka <jh at suse dot cz>
- Cc: Richard Henderson <rth at redhat dot com>,David O'Brien <obrien at FreeBSD dot org>, gcc-patches at gcc dot gnu dot org
- Date: Mon, 05 May 2003 14:36:49 +0200
- Subject: Re: [PATCH] add __amd64__ predefined symbols
- References: <20030426193937.GA11156@dragon.nuxi.com><20030426194206.GA15983@gee.suse.de><20030426221556.GA4792@kam.mff.cuni.cz><20030501181032.GF31113@redhat.com><20030501185206.GQ30033@kam.mff.cuni.cz>
Jan Hubicka <email@example.com> writes:
>> On Sun, Apr 27, 2003 at 12:15:56AM +0200, Jan Hubicka wrote:
>> > > > builtin_assert ("machine=x86_64"); \
>> > The naming change is bit problematic. We still have only one choice to
>> > define for "machine" ...
>> Um, no, assertions are pair associations, not assignments.
>> You can have more than one.
> As Zack mentioned the assertions are obsoletted now, so Andreas is
> testing whether removing the assertion breaks something. Would that be
> OK for you? (done for both 3.3.1 and mainline)
I didn't notice directly any problems, so it seems to be fine,
SuSE Labs firstname.lastname@example.org