This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFC] PowerPC select_section / unique_section


On Wed, Sep 04, 2002 at 01:09:58AM -0400, David Edelsohn wrote:
> Richard> I'm not fond of the ifdef.  A boolean on the target structure
> Richard> would be better IMO.
> 
> 	Okay, but what concerns me is the overlap between
> targetm.in_small_data_p and the new targetm.readonly_small_data_p.  The
> logic will be split between those two, nested functions which will
> interact in complicated and potentially confusing ways.

Err, no, that's not what I mean.  A boolean field (not function)
that says whether small data continues to be read only as well.



r~


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]