This is the mail archive of the
mailing list for the GCC project.
Re: Reformatting and minor code changes for dwarf2out.c
- From: kenner at vlsi1 dot ultra dot nyu dot edu (Richard Kenner)
- To: rth at redhat dot com
- Cc: gcc-patches at gcc dot gnu dot org
- Date: Wed, 26 Dec 01 09:51:52 EST
- Subject: Re: Reformatting and minor code changes for dwarf2out.c
Please do not un-factor code like this. I find the later much
harder to read. In addition, with ENABLE_RTL_CHECKING, this
My reasoning is that it's a tradeoff between code being simpler and being
smaller. Both simpler and smaller make the code easier to read. Here they
are in conflict and I made the judgement that smaller was preferred here,
though, as you've pointed out, one could easily make the opposite judgement.
You are undoing Kaveh's work to eliminate -Wcast-qual warnings.
I don't follow.
- static void
- add_incomplete_type (type)
- tree type;
- VARRAY_PUSH_TREE (incomplete_types, type);
Why? Yes, it was used one place, so what? Mark it inline if you must.
It was used in one place *and* was one line long. It wasn't an efficiency
issue, but one where I felt the additional level of abstraction made the
code harder to read not easier.
So you've proven then that we won't get error_mark_node here
and crash with ENABLE_TREE_CHECKING on the DECL_IGNORED_P?
I missed that. Will fix.
And, as with any change to one of the debug emitters, you ran
the GDB testsuite to verify no regressions as well, right?
No, I didn't believe I was making any functional changes to the emitter, as