This is the mail archive of the
mailing list for the GCC project.
Re: [patches] Re: combine and noop moves, take 2
> What if we enshrine INT_MAX as the meaning "a noop move", by
> #define NOOP_MOVE_INSN_CODE INT_MAX
> Then noop_move_p has a nice fast path to returning true for
> this case. It might not make that much difference, but at
> least it would document a bit more what's going on.
My original tought was to avoid setting the code back to insn, but this
looks like better solution.