This is the mail archive of the
mailing list for the GCC project.
Re: rtx_cost vs magic constants
- To: Richard Henderson <rth at cygnus dot com>
- Subject: Re: rtx_cost vs magic constants
- From: Bernd Schmidt <bernds at redhat dot co dot uk>
- Date: Fri, 15 Sep 2000 10:47:40 +0100 (BST)
- cc: gcc-patches at gcc dot gnu dot org
On Thu, 14 Sep 2000, Richard Henderson wrote:
> When COSTS_N_INSNS was added to rtl.h, its definition was changed
> from (x*2) to (x*4) for some reason. In any case, it seems a good
> excuse to get rid of a bushel of hard-coded numbers.
FWIW, I changed it to 4 because that is closer to the original definition
(x * 4 - 2), and some targets have hard-coded constants that most likely
work better with a definition of (x * 4)...