This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: GCC 2.95.2 and GLIBC 2.1.93, broken streambuf.h


On Fri, Sep 01, 2000 at 11:14:01PM -0400, Ben Collins wrote:
> I saw this posted about 2 weeks ago to the libc-alpha list, and Ulrich's
> answer was basically that gcc was at fault. I never saw it come up on the
> gcc lists, and a web search shows nothing in the gcc-bugs archives.
> 
> Basically installing glibc 2.1.9[123] built with gcc-2.95.2 will not allow
> C++ applications to compile. Here's the error:

If you want a patch, have a look at compat-egcs-6.2-1.1.2.9 sources rpm in
rawhide, particularly egcs-libio.patch. It should apply cleanly to both egcs
1.1.2 and gcc 2.95.x and is basically what was applied to mainline CVS gcc
last year.

	Jakub

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]