This is the mail archive of the gcc-help@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: httpd startup error


On 3/13/13, andyroo <asmith@kinghoster.co.uk> wrote:
>
> I am inexperienced with gcc and the way the libraries function.
>
> I need some help to get my httpd to start again. 	
>
>
> I am using cpanel and I get the following message when trying to start the
> httpd service:
>
> "
> httpd: Syntax error on line 40 of /usr/local/apache/conf/httpd.conf: Syntax
> error on line 9 of /usr/local/apache/conf/php.conf: Cannot load
> /usr/local/apache/modules/mod_suphp.so into server: /lib/libc.so.6: version
> `GLIBC_2.17' not found (required by /usr/lib/libstdc++.so.6)
> "

This is not, properly speaking, a GCC issue.  The error message means
that you have a version of mod_suphp.so or libstdc++.so that was built
on a system with a newer glibc than the one you are trying to run it
on.  glibc does not provide forward compatibility.  After you build a
shared library, you must run it on a system that has at least that
same glibc version, not an earlier one.

Ian


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]