This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Trouble executing an application that requires

Venu Satuluri wrote:

> I am not sure if I understood you completely. The version I have - 3.0.4 -
> is close to the latest one. The application I am trying to run was not
> compiled with a libstdc++ newer than 3.0.4, I think. I don't have the
> source of the package, so recompiling the source is not an option. corresponds to gcc version 3.0.4, released 2002-02-20
and is not anywhere near being "close to the latest one"; it is in fact
very ancient.  The current version is, corresponding
to gcc-4.1.1. corresponds to gcc versions 3.2.x and 3.3.x.  The error
means you are trying to compile a binary compiled by g++ of that vintage
but you are missing the required shared library.  There is absolutely no
way to just try to fake it by fooling it into using an older version of
the library, that is the whole point for having versions to these things
-- they are not forward compatible.

You don't have to recompile the app, but you need to install a
functioning on your system.  Most distros have this as a
simple package that you can easily install without having to compile
anything.  Look for "libstdc++-5" or similar in your package list.  Or
alternatively, install your distro's gcc-3.3 package.  Failing all of
that, download and build the source to gcc-3.3 yourself, and then insure
that the installed is either in the system location or in
the LD_RUN_PATH when trying to run the binary.

For more information: <>


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]