This is the mail archive of the gcc-help@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: gcc version 2.8.1 compilation problem


Paresh Pandya <pv_pandya@yahoo.com> writes:

> I am using gcc version 2.8.1 on HP-UX B.11.11. I am
> trying to compile my ÂCÂ program with 64-bit version
> library. It gives following error:
> 
> Not a valid library (invalid magic number). Possibly a
> 64-bit PA archive library (Mismatched ABI).
> 
> Is gcc 2.8.1 support 64-bit version? How can I compile
> with 64-bit version library?

It's extremely unlikely that you got that error from gcc.  It is much
more likely that you got the error from the linker.

Current versions of gcc does appear to support 64-bit code on HP-UX.
gcc 2.8.1 is very very old--it was released in March 1998, over 7
years ago.  I don't know whether it supported 64-bit HP-UX code.  The
current version of gcc is 4.0.

Ian


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]