This is the mail archive of the fortran@gcc.gnu.org mailing list for the GNU Fortran project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Difficulties building GFortran under SGI


On Wed, Oct 25, 2006 at 02:28:33PM +0200, Philippe Schaffnit wrote:
>
>Hi!
>
>I managed to compile GFortran under SGI Irix once month ago, but I don't
>seem to succeed any more... The whole system is not really up to date,
>so it could come from an outdated tool (ot simply an error on my
>part)... I keep getting the followin error:
>
>if [ xinfo = xinfo ]; then \
>          rm -f doc/gfortran.info-*; \
>          makeinfo --split-size=5000000 --split-size=5000000
>--split-size=5000000 -I /USER/philippe/Irix/Gcc_Sources/gcc/doc/include
>-I /USER/philippe/Irix/Gcc_Sources/gcc/fortran \
>            -o doc/gfortran.info
>/USER/philippe/Irix/Gcc_Sources/gcc/fortran/gfortran.texi; \
>        else true; fi
>makeinfo: getwd: doc/gfortran.info, 
>make[3]: *** [doc/gfortran.info] Error 1
>make[3]: Leaving directory `/USER/philippe/Irix/Compilation/Temp/gcc'
>make[2]: *** [all-stage3-gcc] Error 2
>make[2]: Leaving directory `/USER/philippe/Irix/Compilation/Temp'
>make[1]: *** [stage3-bubble] Error 2
>make[1]: Leaving directory `/USER/philippe/Irix/Compilation/Temp'
>make: *** [all] Error 2
>
>Can anyone suggest something? Turning off this makeinfo thing would also
>be accaptable for me...

IIRC there should be a patch in one of the reports for
http://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=WAITING&bug_status=SUSPENDED&field0-0-0=product&type0-0-0=substring&value0-0-0=makeinfo&field0-0-1=component&type0-0-1=substring&value0-0-1=makeinfo&field0-0-2=short_desc&type0-0-2=substring&value0-0-2=makeinfo&field0-0-3=status_whiteboard&type0-0-3=substring&value0-0-3=makeinfo

http://gcc.gnu.org/PR27516 is a little different since in this situation
one of the tools were not available.

You could try to pass MAKEINFO=/bin/false to configure/make to avoid building
the docs. I don't know offhand if doing make bootstrap && make -k install
would avoid building the docs.

HTH,


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]