Bug 9916 - [3.2 regression] ICE with noreturn function in ?: statement
[3.2 regression] ICE with noreturn function in ?: statement
Status: RESOLVED FIXED
Product: gcc
Classification: Unclassified
Component: c++
3.2.2
: P3 normal
: ---
Assigned To: Not yet assigned to anyone
: ice-on-valid-code
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-03 12:46 UTC by sobe
Modified: 2003-07-25 17:33 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
agent_triggerbug.ii.bz2 (13.76 KB, application/octet-stream)
2003-05-21 15:17 UTC, sobe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sobe 2003-03-03 12:46:01 UTC
internal compiler error.

Release:
gcc-3.2.2 compiled with 'make bootstrap'

Environment:
cygwin-w32
Comment 1 Wolfgang Bangerth 2003-03-03 13:42:06 UTC
From: Wolfgang Bangerth <bangerth@ticam.utexas.edu>
To: gcc-gnats@gcc.gnu.org
Cc:  
Subject: Re: c++/9916
Date: Mon, 3 Mar 2003 13:42:06 -0600 (CST)

 The other report I had in mind is PR 7050. It has a similar problem, but 
 also ICEs with 3.3 and mainline.
 
 W.
 
 -------------------------------------------------------------------------
 Wolfgang Bangerth             email:            bangerth@ticam.utexas.edu
                               www: http://www.ticam.utexas.edu/~bangerth/
 
 
Comment 2 Wolfgang Bangerth 2003-03-03 14:36:50 UTC
State-Changed-From-To: open->analyzed
State-Changed-Why: Confirmed. This is the following problem:
    ---------------------
    void no_return () __attribute__((__noreturn__));
    int i
     = (true ? 0 : (no_return(), 0));
    -------------------------------
    It is fixed in 3.3 and 3.4, though, so will probably not
    be fixed for 3.2.x. I keep it open until we decide to
    abandon the 3.2 branch, since it is a regression (didn't
    ICE with 3.0).
    
    W.
Comment 3 Joe Buck 2003-04-25 20:03:28 UTC
State-Changed-From-To: analyzed->closed
State-Changed-Why: Fixed for 3.3.