Bug 9899 - [tru64 5.0] genattrtab crashes
Summary: [tru64 5.0] genattrtab crashes
Status: RESOLVED DUPLICATE of bug 6680
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 3.2.2
: P2 critical
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-03-02 03:06 UTC by a.melnik
Modified: 2003-06-25 17:37 UTC (History)
2 users (show)

See Also:
Host: alphaev68-dec-osf5.0
Target: alphaev68-dec-osf5.0
Build: alphaev68-dec-osf5.0
Known to work:
Known to fail:
Last reconfirmed: 2003-06-18 06:13:34


Attachments
predict.i.bz2 (36.51 KB, application/octet-stream)
2003-05-21 15:17 UTC, a.melnik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a.melnik 2003-03-02 03:06:00 UTC
Bootstrap fails with:
  ../../gcc-3.2.2/gcc/predict.c: In function `propagate_freq':
  ../../gcc-3.2.2/gcc/predict.c:708: Internal compiler error in @@, at F:537415248Pon:

while compiling:
  stage2/xgcc -Bstage2/ -B/usr/local/alphaev68-dec-osf5.0/bin/ -c -DIN_GCC    -g -O2 -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wtraditional -pedantic -Wno-long-long  -DHAVE_CONFIG_H    -I. -I. -I../../gcc-3.2.2/gcc -I../../gcc-3.2.2/gcc/. -I../../gcc-3.2.2/gcc/config -I../../gcc-3.2.2/gcc/../include ../../gcc-3.2.2/gcc/predict.c -o predict.o

Release:
3.2.2

Environment:
alphaev68-dec-osf5.0, Tru64 v5.0a

How-To-Repeat:
make bootstrap. Same result with CC=/usr/bin/cc, CC=gcc 3.0.4.
Comment 1 Dara Hazeghi 2003-05-14 12:12:29 UTC
From: Dara Hazeghi <dhazeghi@yahoo.com>
To: A.Melnik@upc.kiev.ua, gcc-bugs@gcc.gnu.org, gcc-gnats@gcc.gnu.org
Cc:  
Subject: Re: bootstrap/9899: bootstrap failed on stage3 build
Date: Wed, 14 May 2003 12:12:29 -0700

 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit- 
 trail&database=gcc&pr=9899
 
 Hello,
 
 looks like you found a bug. However gcc 3.2 branch is now officially  
 closed, so would it be possible for you to check with gcc 3.3, and see  
 if this problems still occurs (I can't build a cross compiler due to  
 other bugs :-( )? Thanks,
 
 Dara
 

Comment 2 Dara Hazeghi 2003-05-16 11:27:08 UTC
From: Dara Hazeghi <dhazeghi@yahoo.com>
To: Oleksiy Melnyk <O.Melnyk@upc.kiev.ua>
Cc: gcc-gnats@gcc.gnu.org, roger@www.eyesopen.com
Subject: Re: bootstrap/9899: bootstrap failed on stage3 build
Date: Fri, 16 May 2003 11:27:08 -0700 (PDT)

 --- Oleksiy Melnyk <O.Melnyk@upc.kiev.ua> wrote:
 > Unfortunatelly I can't check _that_ error - another
 > one on the way:-(.
 > Should I report that bug, or wait for a newer OS
 > version(I'll got one next month)?
 
 Well, ideally we'd like to fix this problem on this
 platform... Roger, does this look familiar to you by
 any chance? Thanks,
 
 Dara
 > 
 > ...
 > stage1/xgcc -Bstage1/
 > -B/usr/local/alphaev68-dec-osf5.0/bin/ -g -O2
 > -DIN_GCC 
 >   -W -Wall -Wwrite-strings -Wstrict-prototypes
 > -Wmissing-prototypes 
 > -Wtraditional -pedantic -Wno-long-long  
 > -DHAVE_CONFIG_H -DGENERATOR_FILE  -o 
 > genattrtab genattrtab.o genautomata.o rtl.o
 > read-rtl.o bitmap.o ggc-none.o 
 > gensupport.o insn-conditions.o print-rtl1.o errors.o
 > varray.o 
 > ../libiberty/libiberty.a -lm
 > 
 > ./genattrtab ../../gcc-3.3/gcc/config/alpha/alpha.md
 > > tmp-attrtab.c
 > Check description...genattrtab: Internal error:
 > /bin/sh: 512435 Memory fault - 
 > core dumped
 > make[2]: *** [s-attrtab] Error 139
 > make[2]: Leaving directory
 > `/usr/local/src/gcc-build/gcc'
 > make[1]: *** [stage2_build] Error 2
 > make[1]: Leaving directory
 > `/usr/local/src/gcc-build/gcc'
 > make: *** [bootstrap] Error 2
 > 
 > $ dbx genattrtab core
 > dbx version 5.0
 > Type 'help' for help.
 > Core file created by program "genattrtab"
 > 
 > signal Segmentation fault at >*[strlen,
 > 0x3ff801bbd80]  ldq_u   t0, 0(a0)
 > (dbx) tstack
 > 
 > Thread 0x3:
 >  >  0 strlen(0x14000ce28, 0x1400002c0, 0x0,
 > 0x1400181f8, 0x3ffc0087f80) 
 > [0x3ff801bbd80]
 >     1 _doprnt_dis(0x14000a4c3, 0x10000001c,
 > 0x11fffbec0, 0x10, 0x0) 
 > [0x3ff801bf298]
 >     2 _doprnt(0x0, 0x14009d680, 0x3ff8015a26c,
 > 0x11fffbf50, 0x100000008) 
 > [0x3ff800d3690]
 >     3 vfprintf(0x11fffbf50, 0x100000008,
 > 0x14000a4c3, 0x3ffc0089c70, 0x0) 
 > [0x3ff8015a268]
 >     4 internal_error()
 > ["../../gcc-3.3/gcc/errors.c":6, 0x12002e78c]
 >     5 fancy_abort() ["../../gcc-3.3/gcc/errors.c":6,
 > 0x12002e898]
 >     6 evaluate_max_reserv_cycles()
 > ["../../gcc-3.3/gcc/genautomata.c":6, 
 > 0x120016364]
 >     7 main() ["../../gcc-3.3/gcc/genattrtab.c":6,
 > 0x1200120cc]
 
 
 __________________________________
 Do you Yahoo!?
 The New Yahoo! Search - Faster. Easier. Bingo.
 http://search.yahoo.com
Comment 3 Dara Hazeghi 2003-06-16 16:51:16 UTC
Oops, looks like I forgot to ask you some rather important information: what options are you 
passing to configure? Thanks,

Dara
Comment 4 Oleksiy Melnyk 2003-06-17 12:03:53 UTC
Subject: Re:  [tru64 5.0] genattrtab crashes

CVS version does not contains that bug(at least since May 29).

dhazeghi@yahoo.com wrote:
> PLEASE REPLY TO gcc-bugzilla@gcc.gnu.org ONLY, *NOT* gcc-bugs@gcc.gnu.org.
> 
> http://gcc.gnu.org/bugzilla/show_bug.cgi?id=9899
> 
> 
> dhazeghi@yahoo.com changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|dhazeghi@yahoo.com          |
>             Summary|bootstrap failed on stage3  |[tru64 5.0] genattrtab
>                    |build                       |crashes
> 
> 
> ------- Additional Comments From dhazeghi@yahoo.com  2003-06-16 16:51 -------
> Oops, looks like I forgot to ask you some rather important information: what options are you 
> passing to configure? Thanks,
> 
> Dara
> 
> 
> 
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.


Comment 5 Dara Hazeghi 2003-06-17 13:29:20 UTC
By cvs you mean the 3.3 branch, or mainline?
Comment 6 Oleksiy Melnyk 2003-06-17 15:02:42 UTC
Subject: Re:  [tru64 5.0] genattrtab crashes

Not sure - i've got in with just
CVSROOT=:pserver:anoncvs@subversions.gnu.org:/cvsroot/gcc
You known better, i hope:-)

dhazeghi@yahoo.com wrote:
> PLEASE REPLY TO gcc-bugzilla@gcc.gnu.org ONLY, *NOT* gcc-bugs@gcc.gnu.org.
> 
> http://gcc.gnu.org/bugzilla/show_bug.cgi?id=9899
> 
> 
> 
> ------- Additional Comments From dhazeghi@yahoo.com  2003-06-17 13:29 -------
> By cvs you mean the 3.3 branch, or mainline?
> 
> 
> 
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.


Comment 7 Andrew Pinski 2003-06-17 15:04:52 UTC
That is called the mainline would you mind testing a snapshot which is taken from the 3.3 branch?
Comment 8 Oleksiy Melnyk 2003-06-17 15:06:46 UTC
Subject: Re:  [tru64 5.0] genattrtab crashes

O.Melnyk@upc.kiev.ua wrote:
> Not sure - i've got in with just
> CVSROOT=:pserver:anoncvs@subversions.gnu.org:/cvsroot/gcc

PS: and "cvs co gcc"


Comment 9 Oleksiy Melnyk 2003-06-17 15:10:05 UTC
Subject: Re:  [tru64 5.0] genattrtab crashes

pinskia@physics.uc.edu wrote:
> would you mind testing a snapshot which is taken from the 3.3 branch?

Ok. Just need an advice: how to get one? It will take a lot of time for me to 
find all that cvs's options.

Comment 10 Andrew Pinski 2003-06-17 15:14:49 UTC
on the ftp site: ftp://gcc.gnu.org/pub/gcc/snapshots/2003-06-16/gcc-20030616.tar.gz
Comment 11 Dara Hazeghi 2003-06-17 15:18:26 UTC
Alternatively, if you actually need to get the branch from cvs at some point, the instructions at 
http://gcc.gnu.org/cvs.html are correct. .Just do (for the 3.3 branch):
cvs -z3 co -rgcc-3_3-branch gcc

That should work too...
Comment 12 Oleksiy Melnyk 2003-06-17 15:19:52 UTC
Subject: Re:  [tru64 5.0] genattrtab crashes

Thanks. I'll try it tomorrow, about 03:00 GMT.


Comment 13 Oleksiy Melnyk 2003-06-18 05:51:59 UTC
Subject: Re:  [tru64 5.0] genattrtab crashes

Compiling 3.3 version(20030616 snapshot):

CC=cc confingure --disable-threads && make
......
stage1/xgcc -Bstage1/ -B/usr/local/alphaev68-dec-osf5.0/bin/   -g -O2 -DIN_GCC 
   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes 
-Wtraditional -pedantic -Wno-long-long   -DHAVE_CONFIG_H -DGENERATOR_FILE
-o genattrtab \
  genattrtab.o genautomata.o \
  rtl.o read-rtl.o bitmap.o ggc-none.o gensupport.o insn-conditions.o 
print-rtl1.o errors.o \
  varray.o ../libiberty/libiberty.a -lm

./genattrtab ../../gcc-20030616/gcc/config/alpha/alpha.md > tmp-attrtab.c
Check description...genattrtab: Internal error: abort in (null), at cycle in 
definition of reservation `%s':1074458760

Comment 14 Dara Hazeghi 2003-06-18 06:13:34 UTC
Thanks for the feedback! Hopefully somebody will fix this with gcc 3.3.x, but if not, we know it'll 
be fixed with gcc 3.4.

Roger, do you by any chance know which patch fixed this problem on mainline, and whether it 
would be possible to backport it? Thanks.
Comment 15 Dara Hazeghi 2003-06-25 17:30:41 UTC

*** This bug has been marked as a duplicate of 3355 ***
Comment 16 Dara Hazeghi 2003-06-25 17:36:36 UTC
Darn, closed as dup. of wrong one.
Comment 17 Dara Hazeghi 2003-06-25 17:37:03 UTC

*** This bug has been marked as a duplicate of 6680 ***