Bug 98270 - [11 Regression] UBSAN: /gcc/tree-vect-slp.c:2396:16: runtime error: load of value 112, which is not a valid value for type 'bool' since r11-5928-gfc7b4248172561a9ee310e2d43d8a485a5c9e108
Summary: [11 Regression] UBSAN: /gcc/tree-vect-slp.c:2396:16: runtime error: load of v...
Status: RESOLVED DUPLICATE of bug 98393
Alias: None
Product: gcc
Classification: Unclassified
Component: tree-optimization (show other bugs)
Version: 11.0
: P1 normal
Target Milestone: 11.0
Assignee: Richard Biener
URL:
Keywords:
Depends on:
Blocks: ubsan
  Show dependency treegraph
 
Reported: 2020-12-14 09:43 UTC by Martin Liška
Modified: 2021-01-04 11:14 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work: 10.2.0
Known to fail: 11.0
Last reconfirmed: 2020-12-14 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2020-12-14 09:43:29 UTC
Since the revision I see for UBSAN enabled compiler:

$ ./gcc/xgcc -B gcc /home/marxin/BIG/buildbot/buildworker/marxinbox-gcc-ubsan/build/gcc/testsuite/gcc.dg/torture/pr98235.c -O3 -c -fallow-store-data-races
/home/marxin/Programming/gcc/gcc/tree-vect-slp.c:2396:16: runtime error: load of value 112, which is not a valid value for type 'bool'
    #0 0x2e53ba8 in vect_build_slp_instance /home/marxin/Programming/gcc/gcc/tree-vect-slp.c:2396
    #1 0x2e55120 in vect_analyze_slp_instance /home/marxin/Programming/gcc/gcc/tree-vect-slp.c:2565
    #2 0x2e553ce in vect_analyze_slp(vec_info*, unsigned int) /home/marxin/Programming/gcc/gcc/tree-vect-slp.c:2596
    #3 0x2e649ce in vect_slp_analyze_bb_1 /home/marxin/Programming/gcc/gcc/tree-vect-slp.c:4409
    #4 0x2e6572a in vect_slp_region /home/marxin/Programming/gcc/gcc/tree-vect-slp.c:4521
    #5 0x2e67593 in vect_slp_bbs /home/marxin/Programming/gcc/gcc/tree-vect-slp.c:4669
    #6 0x2e67f29 in vect_slp_function(function*) /home/marxin/Programming/gcc/gcc/tree-vect-slp.c:4755
    #7 0x2ea0219 in execute /home/marxin/Programming/gcc/gcc/tree-vectorizer.c:1436
    #8 0x1fe199b in execute_one_pass(opt_pass*) /home/marxin/Programming/gcc/gcc/passes.c:2567
    #9 0x1fe2323 in execute_pass_list_1 /home/marxin/Programming/gcc/gcc/passes.c:2656
    #10 0x1fe23d8 in execute_pass_list_1 /home/marxin/Programming/gcc/gcc/passes.c:2657
    #11 0x1fe23d8 in execute_pass_list_1 /home/marxin/Programming/gcc/gcc/passes.c:2657
    #12 0x1fe2476 in execute_pass_list(function*, opt_pass*) /home/marxin/Programming/gcc/gcc/passes.c:2667
    #13 0x10bc8c5 in cgraph_node::expand() /home/marxin/Programming/gcc/gcc/cgraphunit.c:1829
    #14 0x10be21d in expand_all_functions /home/marxin/Programming/gcc/gcc/cgraphunit.c:1997
    #15 0x10c0342 in symbol_table::compile() /home/marxin/Programming/gcc/gcc/cgraphunit.c:2361
    #16 0x10c0cce in symbol_table::finalize_compilation_unit() /home/marxin/Programming/gcc/gcc/cgraphunit.c:2542
    #17 0x24682ca in compile_file /home/marxin/Programming/gcc/gcc/toplev.c:482
    #18 0x2470b0d in do_compile /home/marxin/Programming/gcc/gcc/toplev.c:2193
    #19 0x2471110 in toplev::main(int, char**) /home/marxin/Programming/gcc/gcc/toplev.c:2332
    #20 0x508734c in main /home/marxin/Programming/gcc/gcc/main.c:39
    #21 0x7ffff6d2a151 in __libc_start_main (/lib64/libc.so.6+0x28151)
    #22 0x9e49fd in _start (/home/marxin/Programming/gcc/objdir/gcc/cc1+0x9e49fd)
Comment 1 Richard Biener 2021-01-04 07:55:55 UTC
Mine.
Comment 2 Richard Biener 2021-01-04 11:14:47 UTC
dup

*** This bug has been marked as a duplicate of bug 98393 ***