Bug 9787 - [Pentium 4] optimization bug with 176.gcc from SPECcpu2000
Summary: [Pentium 4] optimization bug with 176.gcc from SPECcpu2000
Status: RESOLVED DUPLICATE of bug 21920
Alias: None
Product: gcc
Classification: Unclassified
Component: rtl-optimization (show other bugs)
Version: 3.2.2
: P2 critical
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 9788 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-02-21 14:16 UTC by thomas.anders
Modified: 2005-07-23 22:49 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thomas.anders 2003-02-21 14:16:00 UTC
The 176.gcc benchmark from the latest SPECcpu2000 V1.2 benchmark suite (www.spec.org/osg/cpu2000/) gives wrong results ("miscompare") when using optimization levels 1, 2 or 3 (e.g. "-O3") and "-march=pentium4" with gcc 3.2.2 (Release). Unfortunately I can't provide the source code here since it's covered under SPEC's license. A SPEC licensee (from SuSE, RedHat and friends) should be looking at this issue.

Release:
gcc version 3.2.2

Environment:
Intel Pentium 4 1.70GHz
SuSE Linux 8.1, Kernel 2.4.19

How-To-Repeat:
Compile the 176.gcc benchmark from the SPECcpu2000 benchmark suite (www.spec.org/osg/cpu2000/) with OPTIMIZE="-O3 -march=pentium4" using gcc 3.2.2 (Release).
Comment 1 thomas.anders 2003-02-21 14:16:00 UTC
Fix:
Yes, please! ;)
Comment 2 janis187 2003-02-24 16:22:48 UTC
From: Janis Johnson <janis187@us.ibm.com>
To: thomas.anders@blue-cable.de
Cc: gcc-gnats@gcc.gnu.org
Subject: Re: c/9787: optimization bug with 176.gcc from SPECcpu2000
Date: Mon, 24 Feb 2003 16:22:48 -0800

 > The 176.gcc benchmark from the latest SPECcpu2000 V1.2 benchmark suite (www.spec.org/osg/cpu2000/) gives wrong results ("miscompare") when using optimization levels 1, 2 or 3 (e.g. "-O3") and "-march=pentium4" with gcc 3.2.2 (Release). Unfortunately I can't provide the source code here since it's covered under SPEC's license. A SPEC licensee (from SuSE, RedHat and friends) should be looking at this issue.
 
 The source code of the benchmark is GCC and it's covered by
 the GNU General Public License; SPEC can't change that.  The
 input that causes this behavior, however, is a different
 matter.  (This isn't meant to be legal advice.)

Comment 3 Andrew Pinski 2003-05-01 10:22:40 UTC
From: Andrew Pinski <pinskia@physics.uc.edu>
To: gcc-gnats@gcc.gnu.org, gcc-bugs@gcc.gnu.org, nobody@gcc.gnu.org,
   gcc-prs@gcc.gnu.org, thomas.anders@blue-cable.de
Cc: Andrew Pinski <pinskia@physics.uc.edu>
Subject: Re: optimization/9787: [Pentium 4] optimization bug with 176.gcc from SPECcpu2000
Date: Thu, 1 May 2003 10:22:40 -0400

 This is bug is mostly likely an aliasing problem in the source code of  
 gcc in SPEC.
 This has been discussed many times:
 <http://gcc.gnu.org/ml/gcc/2002-01/msg00711.html>
 <http://gcc.gnu.org/ml/gcc/2003-05/msg00013.html>
 
 
 Thanks,
 Andrew Pinski
 
 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit- 
 trail&database=gcc&pr=9787
Comment 4 Andrew Pinski 2003-05-27 15:54:55 UTC
I am closing this bug as the gcc in SPEC2000 violates ANSI/ISO C aliasing rules.
The fix is to change the loop to be a memset call in the SPEC sources (No this will not 
lower the SPEC source at least with gcc).
Comment 5 Andrew Pinski 2005-06-05 08:25:33 UTC
Reopening to ...
Comment 6 Andrew Pinski 2005-06-05 08:25:57 UTC
Mark as a dup of bug 21920.

*** This bug has been marked as a duplicate of 21920 ***