Bug 96165 - internal compiler error during IPA pass: fnsummary
Summary: internal compiler error during IPA pass: fnsummary
Status: RESOLVED DUPLICATE of bug 96130
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 10.1.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-11 13:16 UTC by Jan Palus
Modified: 2020-07-11 13:25 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
preprocessed source file (77.77 KB, text/plain)
2020-07-11 13:16 UTC, Jan Palus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Palus 2020-07-11 13:16:09 UTC
Created attachment 48863 [details]
preprocessed source file

During Mesa compilation gcc segfaults with:


    during IPA pass: fnsummary
    ../src/gallium/drivers/softpipe/sp_tex_sample.c: In function ‘sample_compare’:
    ../src/gallium/drivers/softpipe/sp_tex_sample.c:3862:1: internal compiler error: Segmentation fault

Confirmed on both aarch64 and x86_64, note that issue occurs only if -O flag was passed. Attached source file after preprocessor. Command to reproduce:

   gcc -O2 -c test.c -o test.o
Comment 1 Jakub Jelinek 2020-07-11 13:25:07 UTC
Dup.

*** This bug has been marked as a duplicate of bug 96130 ***