Bug 92079 - ice in operation_could_trap_p, at tree-eh.c:2528
Summary: ice in operation_could_trap_p, at tree-eh.c:2528
Status: RESOLVED DUPLICATE of bug 92063
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 10.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-13 07:25 UTC by David Binderman
Modified: 2019-10-13 07:31 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2019-10-13 00:00:00


Attachments
C source code (68.45 KB, text/x-csrc)
2019-10-13 07:25 UTC, David Binderman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Binderman 2019-10-13 07:25:32 UTC
Created attachment 47028 [details]
C source code

For the attached C code, compiled by recent trunk and compiler flag -O2,
does this:

Python/_warnings.c: In function ‘setup_context’:
Python/_warnings.c:753:13: internal compiler error: in operation_could_trap_p, at tree-eh.c:2528
  753 |             ascii_lower(PyUnicode_READ(kind, data, len-1)) == 'c')
      |             ^~~~~~~~~~~
gcc -g -O3 -Wall -Wextra -pthread -c -fno-strict-aliasing -Wno-unused-result -Wsign-compare -DNDEBUG -g  -O3 -Wall    -std=c99 -Wextra -Wno-unused-result -Wno-unused-parameter -Wno-missing-field-initializers -Wno-cast-function-type -Werror=implicit-function-declaration   -I. -I./Include    -DPy_BUILD_CORE -o Python/Python-ast.o Python/Python-ast.c
0x6af319 operation_could_trap_p(tree_code, bool, bool, tree_node*)
    ../../trunk/gcc/tree-eh.c:2528
0x6af319 operation_could_trap_p(tree_code, bool, bool, tree_node*)
    ../../trunk/gcc/tree-eh.c:2518
0x6af319 tree_could_trap_p(tree_node*)
    ../../trunk/gcc/tree-eh.c:2635
Comment 1 David Binderman 2019-10-13 07:27:34 UTC
The bug seems to start someplace between revision 276650 and 276700.

I will have my usual go at reducing the code.
Comment 2 Andrew Pinski 2019-10-13 07:29:05 UTC
Are you sure it has not been fixed already?
See PR 92063.
Comment 3 Andrew Pinski 2019-10-13 07:31:49 UTC
Yes this was already fixed and yes it is a dup of bug 92063.

*** This bug has been marked as a duplicate of bug 92063 ***