Bug 90956 - Failed on the PRINT
Summary: Failed on the PRINT
Status: RESOLVED DUPLICATE of bug 87695
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 5.4.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-21 12:22 UTC by OC
Modified: 2019-06-23 22:35 UTC (History)
0 users

See Also:
Host: PC; Windows 8.0
Target: Arduino Nano
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
Code (2.99 KB, text/x-csrc)
2019-06-21 12:22 UTC, OC
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OC 2019-06-21 12:22:55 UTC
Created attachment 46508 [details]
Code

Arduino: 1.8.9 (Windows 8.1), Board: "Arduino Nano, ATmega328P"
C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\ToshibaPc\Documents\Arduino\libraries -fqbn=arduino:avr:nano:cpu=atmega328 -vid-pid=1A86_7523 -ide-version=10809 -build-path C:\Users\TOSHIB~1\AppData\Local\Temp\arduino_build_826290 -warnings=all -build-cache C:\Users\TOSHIB~1\AppData\Local\Temp\arduino_cache_410673 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-5.4.0-atmel3.6.1-arduino2.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude-6.3.0-arduino14.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA-1.2.1.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\ToshibaPc\Documents\Irrigator\SW\Orchard\RemoteUnit\RemoteUnit.ino
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\ToshibaPc\Documents\Arduino\libraries -fqbn=arduino:avr:nano:cpu=atmega328 -vid-pid=1A86_7523 -ide-version=10809 -build-path C:\Users\TOSHIB~1\AppData\Local\Temp\arduino_build_826290 -warnings=all -build-cache C:\Users\TOSHIB~1\AppData\Local\Temp\arduino_cache_410673 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-5.4.0-atmel3.6.1-arduino2.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude-6.3.0-arduino14.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA-1.2.1.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\ToshibaPc\Documents\Irrigator\SW\Orchard\RemoteUnit\RemoteUnit.ino
Using board 'nano' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr
Using core 'arduino' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr
Detecting libraries used...
"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10809 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\variants\\eightanaloginputs" "C:\\Users\\TOSHIB~1\\AppData\\Local\\Temp\\arduino_build_826290\\sketch\\RemoteUnit.ino.cpp" -o nul
"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10809 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\variants\\eightanaloginputs" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\libraries\\SPI\\src" "C:\\Users\\TOSHIB~1\\AppData\\Local\\Temp\\arduino_build_826290\\sketch\\RemoteUnit.ino.cpp" -o nul
"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10809 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\variants\\eightanaloginputs" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\libraries\\SPI\\src" "-IC:\\Users\\ToshibaPc\\Documents\\Arduino\\libraries\\RF24" "C:\\Users\\TOSHIB~1\\AppData\\Local\\Temp\\arduino_build_826290\\sketch\\RemoteUnit.ino.cpp" -o nul
Using cached library dependencies for file: C:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\SPI\src\SPI.cpp
Using cached library dependencies for file: C:\Users\ToshibaPc\Documents\Arduino\libraries\RF24\RF24.cpp
Generating function prototypes...
"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10809 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\variants\\eightanaloginputs" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\libraries\\SPI\\src" "-IC:\\Users\\ToshibaPc\\Documents\\Arduino\\libraries\\RF24" "C:\\Users\\TOSHIB~1\\AppData\\Local\\Temp\\arduino_build_826290\\sketch\\RemoteUnit.ino.cpp" -o "C:\\Users\\TOSHIB~1\\AppData\\Local\\Temp\\arduino_build_826290\\preproc\\ctags_target_for_gcc_minus_e.cpp"
"C:\\Program Files (x86)\\Arduino\\tools-builder\\ctags\\5.8-arduino11/ctags" -u --language-force=c++ -f - --c++-kinds=svpf --fields=KSTtzns --line-directives "C:\\Users\\TOSHIB~1\\AppData\\Local\\Temp\\arduino_build_826290\\preproc\\ctags_target_for_gcc_minus_e.cpp"
Compiling sketch...
"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -Wall -Wextra -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10809 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\variants\\eightanaloginputs" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\libraries\\SPI\\src" "-IC:\\Users\\ToshibaPc\\Documents\\Arduino\\libraries\\RF24" "C:\\Users\\TOSHIB~1\\AppData\\Local\\Temp\\arduino_build_826290\\sketch\\RemoteUnit.ino.cpp" -o "C:\\Users\\TOSHIB~1\\AppData\\Local\\Temp\\arduino_build_826290\\sketch\\RemoteUnit.ino.cpp.o"
Compiling libraries...
Compiling library "SPI"
Using previously compiled file: C:\Users\TOSHIB~1\AppData\Local\Temp\arduino_build_826290\libraries\SPI\SPI.cpp.o
Compiling library "RF24"
Using previously compiled file: C:\Users\TOSHIB~1\AppData\Local\Temp\arduino_build_826290\libraries\RF24\RF24.cpp.o
Compiling core...
Using precompiled core: C:\Users\TOSHIB~1\AppData\Local\Temp\arduino_cache_410673\core\core_arduino_avr_nano_cpu_atmega328_0c812875ac70eb4a9b385d8fb077f54c.a
Linking everything together...
"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-gcc" -Wall -Wextra -Os -g -flto -fuse-linker-plugin -Wl,--gc-sections -mmcu=atmega328p -o "C:\\Users\\TOSHIB~1\\AppData\\Local\\Temp\\arduino_build_826290/RemoteUnit.ino.elf" "C:\\Users\\TOSHIB~1\\AppData\\Local\\Temp\\arduino_build_826290\\sketch\\RemoteUnit.ino.cpp.o" "C:\\Users\\TOSHIB~1\\AppData\\Local\\Temp\\arduino_build_826290\\libraries\\SPI\\SPI.cpp.o" "C:\\Users\\TOSHIB~1\\AppData\\Local\\Temp\\arduino_build_826290\\libraries\\RF24\\RF24.cpp.o" "C:\\Users\\TOSHIB~1\\AppData\\Local\\Temp\\arduino_build_826290/..\\arduino_cache_410673\\core\\core_arduino_avr_nano_cpu_atmega328_0c812875ac70eb4a9b385d8fb077f54c.a" "-LC:\\Users\\TOSHIB~1\\AppData\\Local\\Temp\\arduino_build_826290" -lm
C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino\Print.cpp: In function 'println.constprop':
C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino\Print.cpp:136:1: internal compiler error: Segmentation fault
 }
 ^
Please submit a full bug report, with preprocessed source if appropriate. See <http://gcc.gnu.org/bugs.html> for instructions.
lto-wrapper.exe: fatal error: C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc returned 1 exit status
compilation terminated.
c:/program files (x86)/arduino/hardware/tools/avr/bin/../lib/gcc/avr/5.4.0/../../../../avr/bin/ld.exe: error: lto-wrapper failed
collect2.exe: error: ld returned 1 exit status
Using library SPI at version 1.0 in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\SPI 
Using library RF24 at version 1.3.1 in folder: C:\Users\ToshibaPc\Documents\Arduino\libraries\RF24 
exit status 1
Error compiling for board Arduino Nano.
Comment 1 Andrew Pinski 2019-06-23 22:35:45 UTC
Dup.

*** This bug has been marked as a duplicate of bug 87695 ***