User account creation filtered due to spam.

Bug 9038 - -ffixed-line-length-none -x f77-cpp-input gives: Warning: unknown register name line-length-none
Summary: -ffixed-line-length-none -x f77-cpp-input gives: Warning: unknown register na...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 3.4.0
: P3 normal
Target Milestone: 3.4.0
Assignee: Toon Moene
URL:
Keywords:
: 9501 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-12-22 11:46 UTC by bdavis11
Modified: 2003-09-23 22:14 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bdavis11 2002-12-22 11:46:01 UTC
Any source, compile with:

g77 -ffixed-line-length-none -x f77-cpp-input -c blah.f

Release:
gcc 3.3 and 3.4

Environment:
Linux

How-To-Repeat:
See above.
Comment 1 bdavis11 2002-12-22 11:46:01 UTC
Fix:
It's a regression #(*&$(*#&(&(#& !
Comment 2 Toon Moene 2002-12-22 11:52:08 UTC
Responsible-Changed-From-To: unassigned->toon
Responsible-Changed-Why: Fortran Maintainer.
Comment 3 Toon Moene 2002-12-22 11:52:08 UTC
State-Changed-From-To: open->analyzed
State-Changed-Why: Failes on powerpc-unknown-linux-gnu
Comment 4 Toon Moene 2003-01-04 14:21:31 UTC
State-Changed-From-To: analyzed->closed
State-Changed-Why: Fixed.
Comment 5 Toon Moene 2003-01-26 16:17:00 UTC
State-Changed-From-To: closed->analyzed
State-Changed-Why: Opened again because the implemented solution prohibits
    passing -f options when compiling with -x f77-cpp-input.
Comment 6 Toon Moene 2003-02-20 22:08:45 UTC
From: toon@gcc.gnu.org
To: gcc-gnats@gcc.gnu.org
Cc:  
Subject: fortran/9038
Date: 20 Feb 2003 22:08:45 -0000

 CVSROOT:	/cvs/gcc
 Module name:	gcc
 Changes by:	toon@gcc.gnu.org	2003-02-20 22:08:45
 
 Modified files:
 	gcc            : ChangeLog c-opts.c 
 	gcc/f          : ChangeLog news.texi 
 
 Log message:
 	2003-02-20  Toon Moene  <toon@moene.indiv.nluug.nl>
 	
 	PR fortran/9038
 	* c-opts.c (sanitize_cpp_opts): Add Fortran front end
 	options to be ignored.
 	(c_common_decode_option): Ignore them when preprocessing.
 
 Patches:
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&r1=1.16799&r2=1.16800
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/c-opts.c.diff?cvsroot=gcc&r1=1.28&r2=1.29
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/f/ChangeLog.diff?cvsroot=gcc&r1=1.521&r2=1.522
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/f/news.texi.diff?cvsroot=gcc&r1=1.99&r2=1.100
 

Comment 7 Toon Moene 2003-02-21 06:13:03 UTC
From: toon@gcc.gnu.org
To: gcc-gnats@gcc.gnu.org
Cc:  
Subject: fortran/9038
Date: 21 Feb 2003 06:13:03 -0000

 CVSROOT:	/cvs/gcc
 Module name:	gcc
 Branch: 	gcc-3_3-branch
 Changes by:	toon@gcc.gnu.org	2003-02-21 06:13:03
 
 Modified files:
 	gcc            : ChangeLog c-opts.c 
 	gcc/f          : ChangeLog news.texi 
 
 Log message:
 	2003-02-21  Toon Moene  <toon@moene.indiv.nluug.nl>
 	
 	PR fortran/9038
 	* c-opts.c (sanitize_cpp_opts): Add Fortran front end
 	options to be ignored.
 	(c_common_decode_option): Ignore them when preprocessing.
 
 Patches:
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.16114.2.210&r2=1.16114.2.211
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/c-opts.c.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.24&r2=1.24.6.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/f/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.503.2.12&r2=1.503.2.13
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/f/news.texi.diff?cvsroot=gcc&only_with_tag=gcc-3_3-branch&r1=1.92.2.5&r2=1.92.2.6
 
Comment 8 Toon Moene 2003-02-21 15:50:49 UTC
State-Changed-From-To: analyzed->closed
State-Changed-Why: Fixed in 3.3 and 3.4.