Bug 88665 - Arduino: 1.8.8 (Windows Store 1.8.19.0) (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"
Summary: Arduino: 1.8.8 (Windows Store 1.8.19.0) (Windows 10), Board: "Arduino/Genuino...
Status: RESOLVED DUPLICATE of bug 87695
Alias: None
Product: gcc
Classification: Unclassified
Component: lto (show other bugs)
Version: 5.1.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-02 16:56 UTC by ALLEN WYMER
Modified: 2019-01-03 03:45 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
bug report from arduino (8.19 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-01-02 16:56 UTC, ALLEN WYMER
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ALLEN WYMER 2019-01-02 16:56:25 UTC
Created attachment 45317 [details]
bug report from arduino

Arduino: 1.8.8 (Windows Store 1.8.19.0) (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

sketch\stepper.cpp: In function 'get_axis_position_mm':

sketch\stepper.cpp:1233:1: internal compiler error: Segmentation fault

 }

 ^

Please submit a full bug report,

with preprocessed source if appropriate.

See <http://gcc.gnu.org/bugs.html> for instructions.

lto-wrapper.exe: fatal error: C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.19.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avr-gcc returned 1 exit status

compilation terminated.
Comment 1 Andrew Pinski 2019-01-02 21:35:55 UTC
Dup of bug 87695.  NOTE you filed this bug under classpath which is wrong.

*** This bug has been marked as a duplicate of bug 87695 ***
Comment 2 ALLEN WYMER 2019-01-03 03:45:53 UTC
I HAD NO IDEA WHAT I WAS DOING IY JUST SAID REPORT BUG SO I TRIED

Sent from Mail for Windows 10

From: pinskia at gcc dot gnu.org
Sent: Wednesday, January 2, 2019 3:36 PM
To: WOLFCREEK1@COX.NET
Subject: [Bug lto/88665] Arduino: 1.8.8 (Windows Store 1.8.19.0) (Windows10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

https://gcc.gnu.org/bugzilla/show_bug.cgi?id=88665

Andrew Pinski <pinskia at gcc dot gnu.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |RESOLVED
            Version|unspecified                 |5.1.0
          Component|classpath                   |lto
                 CC|                            |marxin at gcc dot gnu.org
         Resolution|---                         |DUPLICATE
            Product|classpath                   |gcc

--- Comment #1 from Andrew Pinski <pinskia at gcc dot gnu.org> ---
Dup of bug 87695.  NOTE you filed this bug under classpath which is wrong.

*** This bug has been marked as a duplicate of bug 87695 ***