Bug 88102 - Implement P0542R5, C++20 contracts
Summary: Implement P0542R5, C++20 contracts
Status: RESOLVED WONTFIX
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: unknown
: P3 enhancement
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks: 88323
  Show dependency treegraph
 
Reported: 2018-11-19 19:43 UTC by Jason Merrill
Modified: 2019-08-08 17:06 UTC (History)
6 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2018-12-03 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Merrill 2018-11-19 19:43:57 UTC
...as revised by P1289R1.

(I'm creating PRs for new features so there's some way of tracking whether someone's working on them)
Comment 1 emsr 2019-03-10 15:41:21 UTC
I saw this through reddit:

https://gitlab.com/lock3/gcc-new.git branch origin/contracts-jac-kona

This user has several interesting branches of contracts and concepts!

Wiki: http://gummif.github.io/blog/contract_code_gen.html
Comment 2 emsr 2019-03-10 15:46:36 UTC
The Wiki I noted was a 3rd party one.
This is the wiki connected to the repo:

https://gitlab.com/lock3/gcc-new/wikis/contract-assertions
Comment 3 Marek Polacek 2019-08-08 17:06:23 UTC
Since contracts were pulled out of C++20, I'm closing this PR.