Bug 87130 - [9 Regression] LTO bootstrap failed with profiledbootstrap
Summary: [9 Regression] LTO bootstrap failed with profiledbootstrap
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 9.0
: P3 normal
Target Milestone: 9.0
Assignee: Martin Liška
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-28 17:05 UTC by H.J. Lu
Modified: 2018-08-29 10:53 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2018-08-28 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.J. Lu 2018-08-28 17:05:52 UTC
On x86-64, r263887 gave

/export/project/git/gcc-bisect-bootstrap/master/263887/bld/./prev-gcc/xg++ -B/export/project/git/gcc-bisect-bootstrap/master/263887/bld/./prev-gcc/ -B/export/project/git/gcc-bisect-bootstrap/master/263887/usr/x86_64-pc-linux-gnu/bin/ -nostdinc++ -B/export/project/git/gcc-bisect-bootstrap/master/263887/bld/prev-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs -B/export/project/git/gcc-bisect-bootstrap/master/263887/bld/prev-x86_64-pc-linux-gnu/libstdc++-v3/libsupc++/.libs  -I/export/project/git/gcc-bisect-bootstrap/master/263887/bld/prev-x86_64-pc-linux-gnu/libstdc++-v3/include/x86_64-pc-linux-gnu  -I/export/project/git/gcc-bisect-bootstrap/master/263887/bld/prev-x86_64-pc-linux-gnu/libstdc++-v3/include  -I/export/project/git/gcc-bisect/gcc/libstdc++-v3/libsupc++ -L/export/project/git/gcc-bisect-bootstrap/master/263887/bld/prev-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs -L/export/project/git/gcc-bisect-bootstrap/master/263887/bld/prev-x86_64-pc-linux-gnu/libstdc++-v3/libsupc++/.libs -no-pie   -g -O2 -fno-checking -flto=jobserver -frandom-seed=1 -fprofile-generate -flto=jobserver -frandom-seed=1 -DIN_GCC     -fno-exceptions -fno-rtti -fasynchronous-unwind-tables -W -Wall -Wno-narrowing -Wwrite-strings -Wcast-qual -Wmissing-format-attribute -Woverloaded-virtual -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings -fno-common  -DHAVE_CONFIG_H -static-libstdc++ -static-libgcc  -o gengtype \
    gengtype.o gengtype-lex.o gengtype-parse.o gengtype-state.o version.o errors.o libcommon.a ../libcpp/libcpp.a ../libiberty/libiberty.a ../libdecnumber/libdecnumber.a ../libbacktrace/.libs/libbacktrace.a libcommon.a ../libcpp/libcpp.a   ../libbacktrace/.libs/libbacktrace.a ../libiberty/libiberty.a ../libdecnumber/libdecnumber.a 
/export/project/git/gcc-bisect/gcc/libiberty/regex.c:1460:5: error: ‘xre_max_failures’ has already been defined
1460 | int re_max_failures = 4000;
     |     ^
/export/project/git/gcc-bisect/gcc/libiberty/regex.c:1460:5: note: previously defined here
lto1: fatal error: errors during merging of translation units
compilation terminated.
lto-wrapper: fatal error: /export/project/git/gcc-bisect-bootstrap/master/263887/bld/./prev-gcc/xg++ returned 1 exit status
compilation terminated.
/usr/local/bin/ld: error: lto-wrapper failed
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:2867: gengtype] Error 1
make[3]: *** Waiting for unfinished jobs....
mv -f Tlto-wrapper lto-wrapper
mv -f Tcollect2 collect2
rm fsf-funding.pod gcov.pod gpl.pod cpp.pod gfdl.pod gcc.pod gcov-dump.pod gcov-tool.pod
make[3]: Leaving directory '/export/project/git/gcc-bisect-bootstrap/master/263887/bld/gcc'
make[2]: *** [Makefile:4767: all-stageprofile-gcc] Error 2
make[2]: Leaving directory '/export/project/git/gcc-bisect-bootstrap/master/263887/bld'
make[1]: *** [Makefile:21882: stageprofile-bubble] Error 2
make[1]: Leaving directory '/export/project/git/gcc-bisect-bootstrap/master/263887/bld'
make: *** [Makefile:22136: profiledbootstrap] Error 2

when GCC was configured with

 --with-build-config=bootstrap-lto --disable-werror
Comment 1 H.J. Lu 2018-08-28 19:13:55 UTC
It is caused by r263880.
Comment 2 Martin Liška 2018-08-28 19:25:06 UTC
Mine.
Comment 3 Martin Liška 2018-08-29 10:49:24 UTC
Author: marxin
Date: Wed Aug 29 10:48:50 2018
New Revision: 263950

URL: https://gcc.gnu.org/viewcvs?rev=263950&root=gcc&view=rev
Log:
Fix thinko in lto.c (PR bootstrap/87130).

2018-08-29  Martin Liska  <mliska@suse.cz>

	PR bootstrap/87130
	* lto.c (read_cgraph_and_symbols): Fix thinko, revert
	to behavior before r263887.

Modified:
    trunk/gcc/lto/ChangeLog
    trunk/gcc/lto/lto.c
Comment 4 Martin Liška 2018-08-29 10:53:40 UTC
Fixed.