Bug 86890 - GCC 8.2.0 fails to build with isl 0.20
Summary: GCC 8.2.0 fails to build with isl 0.20
Status: RESOLVED DUPLICATE of bug 86724
Alias: None
Product: gcc
Classification: Unclassified
Component: other (show other bugs)
Version: 8.2.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-08 15:04 UTC by Freddie Chopin
Modified: 2018-08-08 16:33 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Freddie Chopin 2018-08-08 15:04:55 UTC
When trying to build GCC 8.2.0 with isl 0.20, I see a lot (at least a few dozens) of errors about undeclared functions, like:

-- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 --

g++ -fno-PIE -c   -g -O2 -DIN_GCC  -DCROSS_DIRECTORY_STRUCTURE   -fno-exceptions -fno-rtti -fasynchronous-unwind-tables -W -Wall -Wno-narrowing -Wwrite-strings -Wcast-qual -Wmissing-format-attribute -Woverloaded-virtual -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings   -DHAVE_CONFIG_H -I. -I. -I/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc -I/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/. -I/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/../include -I/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/../libcpp/include -I/home/freddie/bleeding-edge-toolchain/buildNative/prerequisites/gmp-6.1.2/include -I/home/freddie/bleeding-edge-toolchain/buildNative/prerequisites/mpfr-4.0.1/include -I/home/freddie/bleeding-edge-toolchain/buildNative/prerequisites/mpc-1.1.0/include  -I/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/../libdecnumber -I/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/../libdecnumber/dpd -I../libdecnumber -I/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/../libbacktrace -I/home/freddie/bleeding-edge-toolchain/buildNative/prerequisites/isl-0.20/include -I/home/freddie/bleeding-edge-toolchain/buildNative/prerequisites/zlib-1.2.11/include -pipe  -o graphite-isl-ast-to-gimple.o -MT graphite-isl-ast-to-gimple.o -MMD -MP -MF ./.deps/graphite-isl-ast-to-gimple.TPo /home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/graphite-isl-ast-to-gimple.c
/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/graphite-isl-ast-to-gimple.c: In function ‘void ivs_params_clear(ivs_params&)’:
/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/graphite-isl-ast-to-gimple.c:83:7: error: ‘isl_id_free’ was not declared in this scope
       isl_id_free (it->first);
       ^~~~~~~~~~~
/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/graphite-isl-ast-to-gimple.c:83:7: note: suggested alternative: ‘isl_aff_free’
       isl_id_free (it->first);
       ^~~~~~~~~~~
       isl_aff_free

-- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 --

This seems like some header include problems or something like that, as there definitely is a isl_id_free() function in /home/freddie/bleeding-edge-toolchain/buildNative/prerequisites/isl-0.20/include/isl/id.h, which is available in the search path.
Comment 1 graham.stott77 2018-08-08 15:18:38 UTC
isl  0.18 is the supported version for gcc 8 branch.

-------- Original message --------
From: freddie_chopin at op dot pl <gcc-bugzilla@gcc.gnu.org> 
Date: 08/08/2018  16:04  (GMT+00:00) 
To: gcc-bugs@gcc.gnu.org 
Subject: [Bug other/86890] New: GCC 8.2.0 fails to build with isl 0.20 

https://gcc.gnu.org/bugzilla/show_bug.cgi?id=86890

            Bug ID: 86890
           Summary: GCC 8.2.0 fails to build with isl 0.20
           Product: gcc
           Version: 8.2.0
            Status: UNCONFIRMED
          Severity: normal
          Priority: P3
         Component: other
          Assignee: unassigned at gcc dot gnu.org
          Reporter: freddie_chopin at op dot pl
  Target Milestone: ---

When trying to build GCC 8.2.0 with isl 0.20, I see a lot (at least a few
dozens) of errors about undeclared functions, like:

-- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 --

g++ -fno-PIE -c   -g -O2 -DIN_GCC  -DCROSS_DIRECTORY_STRUCTURE  
-fno-exceptions -fno-rtti -fasynchronous-unwind-tables -W -Wall -Wno-narrowing
-Wwrite-strings -Wcast-qual -Wmissing-format-attribute -Woverloaded-virtual
-pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings  
-DHAVE_CONFIG_H -I. -I.
-I/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc
-I/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/.
-I/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/../include
-I/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/../libcpp/include
-I/home/freddie/bleeding-edge-toolchain/buildNative/prerequisites/gmp-6.1.2/include
-I/home/freddie/bleeding-edge-toolchain/buildNative/prerequisites/mpfr-4.0.1/include
-I/home/freddie/bleeding-edge-toolchain/buildNative/prerequisites/mpc-1.1.0/include
 -I/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/../libdecnumber
-I/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/../libdecnumber/dpd
-I../libdecnumber
-I/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/../libbacktrace
-I/home/freddie/bleeding-edge-toolchain/buildNative/prerequisites/isl-0.20/include
-I/home/freddie/bleeding-edge-toolchain/buildNative/prerequisites/zlib-1.2.11/include
-pipe  -o graphite-isl-ast-to-gimple.o -MT graphite-isl-ast-to-gimple.o -MMD
-MP -MF ./.deps/graphite-isl-ast-to-gimple.TPo
/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/graphite-isl-ast-to-gimple.c
/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/graphite-isl-ast-to-gimple.c:
In function ‘void ivs_params_clear(ivs_params&)’:
/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/graphite-isl-ast-to-gimple.c:83:7:
error: ‘isl_id_free’ was not declared in this scope
       isl_id_free (it->first);
       ^~~~~~~~~~~
/home/freddie/bleeding-edge-toolchain/sources/gcc-8.2.0/gcc/graphite-isl-ast-to-gimple.c:83:7:
note: suggested alternative: ‘isl_aff_free’
       isl_id_free (it->first);
       ^~~~~~~~~~~
       isl_aff_free

-- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 -- >8 --

This seems like some header include problems or something like that, as there
definitely is a isl_id_free() function in
/home/freddie/bleeding-edge-toolchain/buildNative/prerequisites/isl-0.20/include/isl/id.h,
which is available in the search path.
Comment 2 Freddie Chopin 2018-08-08 15:22:56 UTC
Prerequisites docs say "isl Library version 0.15 or later". Configure script also accepts 0.20 just fine.

BTW - 0.19 builds and works OK.
Comment 3 Andrew Pinski 2018-08-08 16:33:59 UTC
Already fixed in the branches. Dup of bug 86724.

*** This bug has been marked as a duplicate of bug 86724 ***