Bug 86639 - building gcc from source fails with Mac OS 10.9
Summary: building gcc from source fails with Mac OS 10.9
Status: RESOLVED DUPLICATE of bug 82092
Alias: None
Product: gcc
Classification: Unclassified
Component: other (show other bugs)
Version: 8.1.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-23 09:11 UTC by zf
Modified: 2018-07-23 11:44 UTC (History)
1 user (show)

See Also:
Host:
Target: x86_64-apple-darwin
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
configure output (1.17 KB, text/plain)
2018-07-23 09:11 UTC, zf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zf 2018-07-23 09:11:05 UTC
Created attachment 44420 [details]
configure output

I try to build gcc 8.1.0 from source on a Mac with OS 10.9.5.
Build fails with following error (see end of attached gcc-make-output.txt):

A linker snapshot was created at:
	/tmp/libgcc_s.dylib-2018-06-23-105655.ld-snapshot
ld: Assertion failed: (cfiStartsArray[i] != cfiStartsArray[i-1]), function parse, file /SourceCache/ld64/ld64-241.9/src/ld/parsers/macho_relocatable_file.cpp, line 1745.
collect2: error: ld returned 1 exit status
make[3]: *** [libgcc_s.dylib] Error 1
make[2]: *** [all-stage1-target-libgcc] Error 2
make[1]: *** [stage1-bubble] Error 2
make: *** [all] Error 2

I tried on two different Mac with OS 10.9.5, I even did a clean install of OS 10.9.5 and the developer tools, I run always in the same error. 

I can build gcc 7.3.0 with OS 10.9.5, or gcc 8.1.0 with OS 10.13 without any error. 

I attached the output of:

$ ../configure --prefix=/usr/local/gcc-8.1 \
>              --with-gmp=/usr/local/gcc-8.1 \
>              --with-mpfr=/usr/local/gcc-8.1 \
>              --with-mpc=/usr/local/gcc-8.1 \
>              --enable-languages=c,c++,fortran \
>              --with-isl=/usr/local/gcc-8.1 \
>              --program-suffix=-8.1 &> gcc-conf-output.txt


If needed I can also send the complete output of make (large!) 
and the mentioned /tmp/libgcc_s.dylib-2018-06-23-105655.ld-snapshot.
Comment 1 Eric Gallager 2018-07-23 11:44:09 UTC
dup of bug 82092

*** This bug has been marked as a duplicate of bug 82092 ***