Bug 85399 - Redundant SSP clearing before rdssp
Summary: Redundant SSP clearing before rdssp
Status: RESOLVED DUPLICATE of bug 85397
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 8.0.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks: 81652
  Show dependency treegraph
 
Reported: 2018-04-13 21:26 UTC by H.J. Lu
Modified: 2018-04-14 15:23 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.J. Lu 2018-04-13 21:26:17 UTC
Since rdssp has been changed to

;; CET instructions
(define_insn "rdssp<mode>"
  [(set (match_operand:SWI48x 0 "register_operand" "=r")
        (unspec_volatile:SWI48x [(const_int 0)] UNSPECV_NOP_RDSSP))]
  "TARGET_SHSTK"
  "xor{l}\t%k0, %k0\n\trdssp<mskmodesuffix>\t%0"
  [(set_attr "length" "6")
   (set_attr "type" "other")])

      emit_insn (gen_rtx_SET (reg_ssp, const0_rtx));
      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ This is redundant now.
      emit_insn ((word_mode == SImode)
                 ? gen_rdsspsi (reg_ssp)
                 : gen_rdsspdi (reg_ssp));
Comment 1 H.J. Lu 2018-04-14 15:23:28 UTC
This will be fixed by PR 85397.

*** This bug has been marked as a duplicate of bug 85397 ***