Bug 8459 - [cygwin] Internal compiler error in rest_of_compilation, at toplev.c:3491
[cygwin] Internal compiler error in rest_of_compilation, at toplev.c:3491
Status: RESOLVED FIXED
Product: gcc
Classification: Unclassified
Component: c++
3.4.0
: P2 critical
: 3.4.0
Assigned To: Not yet assigned to anyone
: ice-on-valid-code
: 8460 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-05 03:36 UTC by alain.touret
Modified: 2003-07-25 17:33 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
8459.ii.bz2 (17.48 KB, application/octet-stream)
2003-05-21 15:16 UTC, alain.touret
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alain.touret 2002-11-05 03:36:00 UTC
make -f fluid.mak
make[1]: Entering directory `/d/Download/Fltk2.0/fltk/MinGW'
g++  -DUSE_CONF -fno-exceptions -g -O0 -I.. -I../visualc -DFL_SHARED -D_DEBUG -D_MSC_DLL -DWIN32 -D_WINDOWS -DWIN32_LEAN_AND_MEAN -DVC_EXTRA_LEAN -DWIN32_EXTRA_LEAN -save-temps -v  -o ../fluid/file.o -c ../fluid/file.cxx
Reading specs from c:/MinGW/bin/../lib/gcc-lib/mingw32/3.2/specs
Configured with: ../gcc/configure --with-gcc --with-gnu-ld --with-gnu-as --host=mingw32 --target=mingw32 --prefix=/mingw --enable-threads --disable-nls --enable-languages=f77,c++,objc,ada --disable-win32-registry --disable-shared
Thread model: win32
gcc version 3.2 (mingw special 20020817-1)
 c:\MinGW\bin\..\lib\gcc-lib\mingw32\3.2\cpp0.exe -lang-c++ -D__GNUG__=3 -D__DEPRECATED -v -I.. -I../visualc -iprefix c:\MinGW\bin\../lib/gcc-lib/mingw32/3.2/ -D__GNUC__=3 -D__GNUC_MINOR__=2 -D__GNUC_PATCHLEVEL__=0 -D__GXX_ABI_VERSION=102 -D_WIN32 -D__WIN32 -D__WIN32__ -DWIN32 -D__MINGW32__ -D__MSVCRT__ -DWINNT -D_X86_=1 -D_WIN32 -D__WIN32 -D__WIN32__ -D__WIN32__ -D__MINGW32__ -D__MSVCRT__ -D__WINNT__ -D_X86_=1 -D__WIN32 -D__WINNT -Asystem=winnt -D__NO_INLINE__ -D__STDC_HOSTED__=1 -Acpu=i386 -Amachine=i386 -Di386 -D__i386 -D__i386__ -D__tune_i586__ -D__tune_pentium__ -D__stdcall=__attribute__((__stdcall__)) -D__cdecl=__attribute__((__cdecl__)) -D__fastcall=__attribute__((__fastcall__)) -D_stdcall=__attribute__((__stdcall__)) -D_cdecl=__attribute__((__cdecl__)) -D_fastcall=__attribute__((__fastcall__)) -D__declspec(x)=__attribute__((x)) -DUSE_CONF -DFL_SHARED -D_DEBUG -D_MSC_DLL -DWIN32 -D_WINDOWS -DWIN32_LEAN_AND_MEAN -DVC_EXTRA_LEAN -DWIN32_EXTRA_LEAN ../fluid/file.cxx file.ii
GNU CPP version 3.2 (mingw special 20020817-1) (cpplib) (80386, BSD syntax)
ignoring nonexistent directory "c:/MinGW/mingw32/include"
ignoring nonexistent directory "/mingw/lib/gcc-lib/mingw32/3.2/../../../../include/c++/3.2"
ignoring nonexistent directory "/mingw/lib/gcc-lib/mingw32/3.2/../../../../include/c++/3.2/mingw32"
ignoring nonexistent directory "/mingw/lib/gcc-lib/mingw32/3.2/../../../../include/c++/3.2/backward"
ignoring nonexistent directory "/mingw/lib/gcc-lib/mingw32/3.2/../../../../include"
ignoring nonexistent directory "/mingw/include"
ignoring nonexistent directory "/mingw/lib/gcc-lib/mingw32/3.2/include"
ignoring nonexistent directory "/mingw/lib/gcc-lib/mingw32/3.2/../../../../mingw32/include"
ignoring nonexistent directory "/usr/local/mingw32/include"
#include "..." search starts here:
#include <...> search starts here:
 ..
 ../visualc
 c:/MinGW/include/c++/3.2
 c:/MinGW/include/c++/3.2/mingw32
 c:/MinGW/include/c++/3.2/backward
 c:/MinGW/include
 c:/MinGW/lib/gcc-lib/mingw32/3.2/include
End of search list.
 c:\MinGW\bin\..\lib\gcc-lib\mingw32\3.2\cc1plus.exe -fpreprocessed file.ii -quiet -dumpbase file.cxx -g -O0 -version -fno-exceptions -o C:\DOCUME~1\Alain\LOCALS~1\Temp/ccgLaaaa.s
GNU CPP version 3.2 (mingw special 20020817-1) (cpplib) (80386, BSD syntax)
GNU C++ version 3.2 (mingw special 20020817-1) (mingw32)
        compiled by GNU C version 3.2.
../fluid/file.cxx: In function `void fl_end_group()':
../fluid/file.cxx:647: Internal compiler error in rest_of_compilation, at 
   toplev.c:3491
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.
make[1]: *** [../fluid/file.o] Error 1
make[1]: Leaving directory `/d/Download/Fltk2.0/fltk/MinGW'
make: *** [fluid] Error 2

Release:
3.2/3.3/3.4

Environment:
MinGW 2.0 + MSys 1.0.7 on WIndowsXP Home (pentium III)

How-To-Repeat:
compiling this file should return you the same error. 
If not, please ask me for more data.
Comment 1 alain.touret 2002-11-05 03:36:00 UTC
Fix:
no idea yet.
Comment 2 Paolo Carlini 2002-11-05 04:04:59 UTC
State-Changed-From-To: open->feedback
State-Changed-Why: Please follow the detailed bug reporting instructions:
    http://gcc.gnu.org/bugs.html#detailed
    Thanks, Paolo.
Comment 3 Paolo Carlini 2002-11-05 09:31:56 UTC
State-Changed-From-To: feedback->analyzed
State-Changed-Why: Preprocessed source received.
Comment 4 alain.touret 2002-11-15 17:20:25 UTC
From: "Alain Touret" <alain.touret@fnac.net>
To: <gcc-gnats@gcc.gnu.org>, <nobody@gcc.gnu.org>
Cc:  
Subject: Re: c++/8459: Internal compiler error in rest_of_compilation, at toplev.c:3491
Date: Fri, 15 Nov 2002 17:20:25 +0100

 This is a multi-part message in MIME format.
 
 ------=_NextPart_000_0044_01C28CCB.49883C30
 Content-Type: text/plain;
 	charset="iso-8859-1"
 Content-Transfer-Encoding: quoted-printable
 
 Hello,
 
 Perdon me if I disturb you, but have you any news about the following =
 problem ?
 Do you think there is any work around or any patch applicable ?
 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=3Dview%20audit-trail&database=3D=
 gcc&pr=3D8459
 
 Thank you
 
 Alain Touret
 
 ------=_NextPart_000_0044_01C28CCB.49883C30
 Content-Type: text/html;
 	charset="iso-8859-1"
 Content-Transfer-Encoding: quoted-printable
 
 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
 <HTML><HEAD>
 <META http-equiv=3DContent-Type content=3D"text/html; =
 charset=3Diso-8859-1">
 <META content=3D"MSHTML 6.00.2719.2200" name=3DGENERATOR>
 <STYLE></STYLE>
 </HEAD>
 <BODY bgColor=3D#ffffff>
 <DIV><FONT face=3DArial size=3D2>Hello,</FONT></DIV>
 <DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
 <DIV><FONT face=3DArial size=3D2>Perdon me if I disturb you, but have =
 you any news=20
 about the following problem ?</FONT></DIV>
 <DIV><FONT face=3DArial size=3D2>Do you think there is any work around =
 or any patch=20
 applicable ?</FONT></DIV>
 <DIV><FONT face=3DArial size=3D2></FONT><FONT face=3DArial =
 size=3D2></FONT><FONT=20
 face=3DArial size=3D2></FONT><FONT face=3DArial size=3D2></FONT><A=20
 href=3D"http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=3Dview%20audit-trail&a=
 mp;database=3Dgcc&amp;pr=3D8459">http://gcc.gnu.org/cgi-bin/gnatsweb.pl?c=
 md=3Dview%20audit-trail&amp;database=3Dgcc&amp;pr=3D8459</A></DIV>
 <DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
 <DIV><FONT face=3DArial size=3D2>Thank you</FONT></DIV>
 <DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
 <DIV><FONT face=3DArial size=3D2>Alain Touret</FONT></DIV></BODY></HTML>
 
 ------=_NextPart_000_0044_01C28CCB.49883C30--
 
Comment 5 Giovanni Bajo 2003-05-01 15:21:04 UTC
State-Changed-From-To: analyzed->closed
State-Changed-Why: Reduced snippet is:
    ------------------------------------
    struct Foo
    {
        friend __attribute__((dllimport)) void bar();
    };
    
    void func(void)
    {
        bar();
    }
    
    void bar(void)
    {
    }
    ------------------------------------
    pr8549.cpp: In function `void bar()':
    pr8549.cpp:13: Internal compiler error in rest_of_compilation, at toplev.c:3491
    Please submit a full bug report,
    
    This is another report for the infamous regression in
    winnt.c, a bug with dllimport (I think it's the sixth I 
    personally analyzed). So I close it as duplicate of
    pr/7910. Let's hope someone will eventually fix this.