User account creation filtered due to spam.

Bug 8336 - [3.3 only] [SCO5] bootstrap config still tries to use COFF options
Summary: [3.3 only] [SCO5] bootstrap config still tries to use COFF options
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 3.2
: P3 normal
Target Milestone: 3.3.2
Assignee: Kean Johnston
URL:
Keywords: build
Depends on:
Blocks:
 
Reported: 2002-10-24 05:56 UTC by david.sullivan
Modified: 2003-08-24 04:03 UTC (History)
3 users (show)

See Also:
Host: i386-pc-sco3.2v5
Target: i386-pc-sco3.2v5
Build: i386-pc-sco3.2v5
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description david.sullivan 2002-10-24 05:56:02 UTC
If you attempt to bootstrap the compiler using "make bootstrap" on SCO OpenServer 5, it fails because the sco5.cf configuration file tries to use COFF build options (-mcoff) when making the second compiler build with xgcc.  Since COFF support is no longer present in this compiler, the build fails.

Release:
gcc-3.2

Environment:
SCO OpenServer 5

How-To-Repeat:
make bootstrap
Comment 1 Robert Lipe 2002-10-24 09:19:50 UTC
Responsible-Changed-From-To: unassigned->robertl
Responsible-Changed-Why: openserver maintainer
Comment 2 Robert Lipe 2002-10-24 09:19:50 UTC
State-Changed-From-To: open->feedback
State-Changed-Why: There is no sco5.cf in the GCC 3.2 distribution.   I successfully bootstrapped GCC 3.2 on 5.0.6 yesterday and did not see the failure you describe.   Perhaps this is part of some other package?
Comment 3 david.sullivan 2002-10-24 12:25:16 UTC
From: "David Sullivan" <david.sullivan@cci-triad.com>
To: <gcc-gnats@gcc.gnu.org>, <gcc-prs@gcc.gnu.org>,
	 <david.sullivan@ccitriad.com>, <robertl@gcc.gnu.org>,
	 <gcc-bugs@gcc.gnu.org>
Cc:  
Subject: Re: target/8336: bootstrap config still tries to use COFF options
Date: Thu, 24 Oct 2002 12:25:16 -0500

 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit-trail&database=gcc&pr=8
 336
 
 I was a bit foggy when I submitted this this morning.  Apologies to all for
 that.  The issue is within the Makefile in the "gcc" subdirectory.  When you
 run "./configure --with-gnu-as", it places a "-mcoff" option in the makefile
 variable CRTSTUFF_T_CFLAGS_S.  Without the "--with-gnu-as", this variable isn't
 present in the makefile at all.  My assumption was that the problem was in the
 file "sco5.h".
 
 
 

Comment 4 Kean Johnston 2003-05-09 11:53:36 UTC
From: "Kean Johnston" <jkj@sco.com>
To: "'Dara Hazeghi'" <dhazeghi@yahoo.com>, <gcc-gnats@gcc.gnu.org>,
	<david.sullivan@ccitriad.com>
Cc:  
Subject: RE: target/8336: [SCO5] bootstrap config still tries to use COFF options
Date: Fri, 9 May 2003 11:53:36 -0700

 > MAINTAINERS lists you as the current SCO maintainer, so I was 
 > wondering  
 > if you've seen this problem, and might know whether this has 
 > been fixed  
 > on 3.3 branch or trunk?
 Its fixed at the head. Unfortunately I got on board a bit too
 late for getting all the SCO fixes in for 3.3, but Mark says I
 can put them in for 3.3.1. If you're feeling brave you can look
 at what I did at the head and back-patch it to 3.3, or you can
 wait a little for 3.3 to be out so I can get the 3.3.1 branch
 checked out and redo the 3.4 stuff on 3.3.1.
 
 Kean
Comment 5 Dara Hazeghi 2003-05-09 11:59:28 UTC
From: Dara Hazeghi <dhazeghi@yahoo.com>
To: gcc-gnats@gcc.gnu.org, jkj@sco.com, david.sullivan@ccitriad.com
Cc:  
Subject: Re: target/8336: [SCO5] bootstrap config still tries to use COFF options
Date: Fri, 9 May 2003 11:59:28 -0700

 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit- 
 trail&database=gcc&pr=8336
 
 Hello Kean,
 
 MAINTAINERS lists you as the current SCO maintainer, so I was wondering  
 if you've seen this problem, and might know whether this has been fixed  
 on 3.3 branch or trunk?
 
 Thanks,
 
 Dara
 

Comment 6 Dara Hazeghi 2003-06-16 20:09:00 UTC
Kean,

what's the status of 3.3.1 now? Have the changes been merged? Thanks,

Dara
Comment 7 Andrew Pinski 2003-07-28 19:15:15 UTC
Should not be in wating.
Comment 8 Andrew Pinski 2003-08-24 04:03:13 UTC
Was fixed by:

2003-08-08  Kean Johnston

        PR target/9877
        PR target/8336
        * config.gcc (sco3.2v5*): Use elfos.h and dbxelf.h in tm_file;
        Eliminate need for t-sco5gas target fragment.
        No longer build crt{begin,end}S.o, that were used for COFF support.
        * tlink.c (recompile_files): Add missing = in putenv() calls.
        * unwind-dw2.c (_Unwind_GetCFA): Correct return cast.      
        * config/i386/sco5.h: Major overhaul to remove all COFF support  
        * config/i386/t-sco5: Multilib for PIC support
        * config/i386/t-sco5gas: Remove
        * config/i386/i386.c: Check value as well as presence of
        SUPPORTS_ONE_ONLY
        * doc/install.texi: Update for modern SCO instructions
        * fixinc/check.tpl: Allow user to specify diff program for make check
        * fixinc/inclhack.def: Fix several SCO header files, namely string.h,
        math.h, sys/byteorder.h and sys/regset.h.
        * fixinc/fixincl.x: Regenerate
        * fixinc/tests/base/math.h: Update
        * fixinc/tests/base/sys/byteorder.h: Update
        * fixinc/tests/base/string.h: Added 
        * fixinc/tests/base/sys/regset.h: Added
        * testsuite/gcc.dg/nest.c: Allow failure on SCO (-pg not supported)