Bug 8262 - [x86_64] incompatible types in assignment when copying objects of type va_list
Summary: [x86_64] incompatible types in assignment when copying objects of type va_list
Status: RESOLVED DUPLICATE of bug 14557
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 3.2
: P3 normal
Target Milestone: ---
Assignee: Jan Hubicka
URL:
Keywords: rejects-valid
Depends on:
Blocks:
 
Reported: 2002-10-17 12:06 UTC by jkain
Modified: 2005-12-07 17:12 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
varargs.tar.bz2 (4.55 KB, application/octet-stream)
2003-05-21 15:17 UTC, jkain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jkain 2002-10-17 12:06:01 UTC
When gcc 3.2 is used to compile the attached program it incorrectly gives the error:

varargs.c: In function `my_printf':
varargs.c:14: incompatible types in assignment

Release:
gcc version 3.2

Environment:
AMD K8
SuSE Linux 8.1 Beta
Linux Kernel 2.4.19

How-To-Repeat:
gcc -o varargs varargs.c
Comment 1 Wolfgang Bangerth 2003-01-10 17:36:55 UTC
Responsible-Changed-From-To: unassigned->hubicka
Responsible-Changed-Why: Likely knowledgable
Comment 2 Jan Hubicka 2003-04-06 13:13:35 UTC
State-Changed-From-To: open->closed
State-Changed-Why: This is known behaviour becase va_list is internally an array - the program is not allowed to take address of va_list
Comment 3 Andrew Pinski 2005-12-07 17:12:27 UTC
Reopening to ...
Comment 4 Andrew Pinski 2005-12-07 17:12:42 UTC
To close as a dup of bug 14557.

*** This bug has been marked as a duplicate of 14557 ***