Bug 82330 - [7 regression] GCC ICE on i386 building llvm-toolchain-3.8 /<<PKGBUILDDIR>>/lib/Transforms/InstCombine/InstCombineAddSub.cpp:518:8: internal compiler error: in equal_mem_array_ref_p, at tree-ssa-scopedtables.c:429
Summary: [7 regression] GCC ICE on i386 building llvm-toolchain-3.8 /<<PKGBUILDDIR>>/l...
Status: RESOLVED DUPLICATE of bug 82327
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 7.2.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-26 18:58 UTC by Gianfranco
Modified: 2017-09-26 19:01 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gianfranco 2017-09-26 18:58:31 UTC
Hello, as said, since patches added in 20-09 and 21-09 I am getting an ICE on i386 with valid code from llvm-toolchain-3.8
(copy-pasted from my Ubuntu report https://bugs.launchpad.net/ubuntu/+source/gcc-7/+bug/1719710 )

the previous 7.2.0-6ubuntu1 seems to build it just fine
https://launchpadlibrarian.net/338774228/buildlog_ubuntu-artful-i386.llvm-toolchain-3.8_1%3A3.8.1-24ubuntu7ppa2_BUILDING.txt.gz

while 7.2.0-7ubuntu1 ICE now
/<<PKGBUILDDIR>>/lib/Transforms/InstCombine/InstCombineAddSub.cpp: In function ‘llvm::Value* {anonymous}::FAddCombine::simplify(llvm::Instruction*)’:
/<<PKGBUILDDIR>>/lib/Transforms/InstCombine/InstCombineAddSub.cpp:518:8: internal compiler error: in equal_mem_array_ref_p, at tree-ssa-scopedtables.c:429
 Value *FAddCombine::simplify(Instruction *I) {
        ^~~~~~~~~~~
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-7/README.Bugs> for instructions.

see:
https://launchpadlibrarian.net/338562399/buildlog_ubuntu-artful-i386.llvm-toolchain-3.8_1%3A3.8.1-24ubuntu7_BUILDING.txt.gz

Debian Changelog:
+ * Update to SVN 20170923 (r253114) from the gcc-7-branch.
+ - Fix PR libstdc++/79162, PR libstdc++/79162, PR libstdc++/82262,
+ PR libstdc++/82254, PR target/81996 (PPC), PR target/71951 (AArch64),
+ PR sanitizer/81929.
+ * Fix PR go/82284, taken from the trunk. Closes: #876353.

full upstream Changelog:
++2017-09-21 Jonathan Wakely <jwakely@redhat.com>
++
++ * testsuite/25_algorithms/clamp/1.cc: Fix order of arguments and
++ expected results when using predicate defining reverse order.
++ * testsuite/25_algorithms/clamp/constexpr.cc: Likewise.
++
++2017-09-20 Jonathan Wakely <jwakely@redhat.com>
++
++ Backport from mainline
++ 2017-06-14 Jonathan Wakely <jwakely@redhat.com>
++
++ * doc/xml/manual/test.xml: Correct instructions on running tests.
++ * testsuite/27_io/basic_ios/copyfmt/char/1.cc: Adjust to pass when
++ -D_GLIBCXX_USE_CXX11_ABI=0 added to RUNTESTFLAGS.
++ * testsuite/27_io/basic_ios/exceptions/char/1.cc: Likewise.
++ * testsuite/27_io/basic_istream/extractors_arithmetic/char/
++ exceptions_failbit.cc: Likewise.
++ * testsuite/27_io/basic_istream/extractors_arithmetic/wchar_t/
++ exceptions_failbit.cc: Likewise.
++ * testsuite/27_io/basic_istream/extractors_other/char/
++ exceptions_null.cc: Likewise.
++ * testsuite/27_io/basic_istream/extractors_other/wchar_t/
++ exceptions_null.cc: Likewise.
++ * testsuite/27_io/basic_istream/sentry/char/12297.cc: Likewise.
++ * testsuite/27_io/basic_istream/sentry/wchar_t/12297.cc: Likewise.
++ * testsuite/27_io/basic_ostream/inserters_other/char/
++ exceptions_null.cc: Likewise.
++ * testsuite/27_io/basic_ostream/inserters_other/wchar_t/
++ exceptions_null.cc: Likewise.
++ * testsuite/27_io/ios_base/storage/2.cc: Likewise.
++
++ PR libstdc++/79162
++ * include/bits/basic_string.h [!_GLIBCXX_USE_CXX11_ABI]
++ (basic_string::_If_sv): Remove from the overload set when the
++ argument is derived from basic_string.
++
++ PR libstdc++/79162
++ * include/bits/basic_string.h (basic_string::_If_sv): Remove from the
++ overload set when the argument is derived from basic_string.
++ * testsuite/21_strings/basic_string/cons/char/moveable2_c++17.cc: New
++ test.
++ * testsuite/21_strings/basic_string/cons/wchar_t/moveable2_c++17.cc:
++ New test.
++
++ * testsuite/24_iterators/range_access_cpp17.cc: Fix order of dg-do
++ and dg-options directives. Fix invalid test.
++
++ Backport from mainline
++ 2017-09-20 Jonathan Wakely <jwakely@redhat.com>
++
++ PR libstdc++/82262
++ * include/std/optional (__optional_hash_call_base): Add template
++ parameter for remove_const_t<_Tp> and use it consistently.
++ * testsuite/20_util/optional/hash.cc: Test optional<const T>.
++
++ Backport from mainline
++ 2017-09-19 Jonathan Wakely <jwakely@redhat.com>
++
++ PR libstdc++/82254
++ * include/std/type_traits (__is_invocable): Add partial specialization
++ for INVOKE<void> case and remove is_void<R> check from partial
++ specialization for INVOKE<R> case.
++ (__is_nt_invocable_impl): New helper for is_nothrow_invocable_r.
++ (is_nothrow_invocable_r): Use __is_nt_invocable_impl.
++ * testsuite/20_util/is_nothrow_invocable/value.cc: Add tests for
++ conversions that can throw or fail to convert. Use static assert
++ strings to explain negative results.
++ * testsuite/20_util/is_nothrow_invocable/value_ext.cc: Use
++ is_nothrow_constructible in is_nt_invocable_conv.

not sure what can cause such ICE; and I don't know how to debug it further


here you can find the preprocessed source:
https://launchpadlibrarian.net/338562399/buildlog_ubuntu-artful-i386.llvm-toolchain-3.8_1%3A3.8.1-24ubuntu7_BUILDING.txt.gz
Comment 1 Andrew Pinski 2017-09-26 19:01:11 UTC
Dup.

*** This bug has been marked as a duplicate of bug 82327 ***