Bug 82315 - Bootstrap fails with Xcode 9.0 on MAC OS X
Summary: Bootstrap fails with Xcode 9.0 on MAC OS X
Status: RESOLVED DUPLICATE of bug 82092
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 8.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-24 18:13 UTC by Jürgen Reuter
Modified: 2017-09-24 18:27 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail: 8.0
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jürgen Reuter 2017-09-24 18:13:20 UTC
gcc trunk (r253118) fails to bootstrap with Xcode 9.0.
Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/usr/include/c++/4.2.1
Apple LLVM version 9.0.0 (clang-900.0.37)
Target: x86_64-apple-darwin16.7.0
Thread model: posix
InstalledDir: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin
on MAC OS X Sierra 10.12.6. 

/usr/local/packages/gcc_trunk/_build/./gcc/xgcc -B/usr/local/packages/gcc_trunk/_build/./gcc/ -B/usr/local/x86_64-apple-darwin16.7.0/bin/ -B/usr/local/x86_64-apple-darwin16.7.0/lib/ -isystem /usr/local/x86_64-apple-darwin16.7.0/include -isystem /usr/local/x86_64-apple-darwin16.7.0/sys-include    -O2  -g -O2 -DIN_GCC    -W -Wall -Wno-narrowing -Wwrite-strings -Wcast-qual -Wno-format -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition  -isystem ./include   -mmacosx-version-min=10.5 -pipe -fno-common -g -DIN_LIBGCC2 -fbuilding-libgcc -fno-stack-protector  -dynamiclib -nodefaultlibs -install_name /usr/local/lib/libgcc_s.1.dylib -single_module -o ./libgcc_s.dylib -Wl,-exported_symbols_list,libgcc.map -compatibility_version 1 -current_version 1.0 -g -O2 -B./ _muldi3_s.o _negdi2_s.o _lshrdi3_s.o _ashldi3_s.o _ashrdi3_s.o _cmpdi2_s.o _ucmpdi2_s.o _clear_cache_s.o _trampoline_s.o __main_s.o _absvsi2_s.o _absvdi2_s.o _addvsi3_s.o _addvdi3_s.o _subvsi3_s.o _subvdi3_s.o _mulvsi3_s.o _mulvdi3_s.o _negvsi2_s.o _negvdi2_s.o _ctors_s.o _ffssi2_s.o _ffsdi2_s.o _clz_s.o _clzsi2_s.o _clzdi2_s.o _ctzsi2_s.o _ctzdi2_s.o _popcount_tab_s.o _popcountsi2_s.o _popcountdi2_s.o _paritysi2_s.o _paritydi2_s.o _powisf2_s.o _powidf2_s.o _powixf2_s.o _powitf2_s.o _mulhc3_s.o _mulsc3_s.o _muldc3_s.o _mulxc3_s.o _multc3_s.o _divhc3_s.o _divsc3_s.o _divdc3_s.o _divxc3_s.o _divtc3_s.o _bswapsi2_s.o _bswapdi2_s.o _clrsbsi2_s.o _clrsbdi2_s.o _fixunssfsi_s.o _fixunsdfsi_s.o _fixunsxfsi_s.o _fixsfdi_s.o _fixdfdi_s.o _fixxfdi_s.o _fixunssfdi_s.o _fixunsdfdi_s.o _fixunsxfdi_s.o _floatdisf_s.o _floatdidf_s.o _floatdixf_s.o _floatundisf_s.o _floatundidf_s.o _floatundixf_s.o _fixsfti_s.o _fixdfti_s.o _fixxfti_s.o _fixtfti_s.o _fixunssfti_s.o _fixunsdfti_s.o _fixunsxfti_s.o _fixunstfti_s.o _floattisf_s.o _floattidf_s.o _floattixf_s.o _floattitf_s.o _floatuntisf_s.o _floatuntidf_s.o _floatuntixf_s.o _floatuntitf_s.o _divdi3_s.o _moddi3_s.o _divmoddi4_s.o _udivdi3_s.o _umoddi3_s.o _udivmoddi4_s.o _udiv_w_sdiv_s.o darwin-64_s.o cpuinfo_s.o sfp-exceptions_s.o addtf3_s.o divtf3_s.o eqtf2_s.o getf2_s.o letf2_s.o multf3_s.o negtf2_s.o subtf3_s.o unordtf2_s.o fixtfsi_s.o fixunstfsi_s.o floatsitf_s.o floatunsitf_s.o fixtfdi_s.o fixunstfdi_s.o floatditf_s.o floatunditf_s.o fixtfti_s.o fixunstfti_s.o floattitf_s.o floatuntitf_s.o extendsftf2_s.o extenddftf2_s.o extendxftf2_s.o trunctfsf2_s.o trunctfdf2_s.o trunctfxf2_s.o enable-execute-stack_s.o unwind-dw2_s.o unwind-dw2-fde-darwin_s.o unwind-sjlj_s.o unwind-c_s.o emutls_s.o libgcc.a -lc
0  0x10dfccb1b  __assert_rtn + 129
0  0x10dfccb1b  __assert_rtn + 129
1  0x10dfe023a  mach_o::relocatable::Parser<x86_64>::parse(mach_o::relocatable::ParserOptions const&) + 3030
1  0x10dfe023a  mach_o::relocatable::Parser<x86_64>::parse(mach_o::relocatable::ParserOptions const&) + 3030
2  0x10dfd7bcc  mach_o::relocatable::Parser<x86_64>::parse(unsigned char const*, unsigned long long, char const*, long, ld::File::Ordinal, mach_o::relocatable::ParserOptions const&) + 282
2  0x10dfd7bcc  mach_o::relocatable::Parser<x86_64>::parse(unsigned char const*, unsigned long long, char const*, long, ld::File::Ordinal, mach_o::relocatable::ParserOptions const&) + 282
3  0x10e01cae4  ld::tool::InputFiles::makeFile(Options::FileInfo const&, bool) + 830
3  0x10e01cae4  ld::tool::InputFiles::makeFile(Options::FileInfo const&, bool) + 830
4  0x10e01f46d  ld::tool::InputFiles::parseWorkerThread() + 497
4  0x10e01f46d  ld::tool::InputFiles::parseWorkerThread() + 497
5  0x7fffdd55b93b  _pthread_body + 180
5  0x7fffdd55b93b  _pthread_body + 180
6  0x7fffdd55b887  _pthread_body + 0
6  0x7fffdd55b887  _pthread_body + 0
A linker snapshot was created at:
	/tmp/libgcc_s.dylib-2017-08-24-013125.ld-snapshot
ld: Assertion failed: (cfiStartsArray[i] != cfiStartsArray[i-1]), function parse, file /Library/Caches/com.apple.xbs/Sources/ld64/ld64-302.3/src/ld/parsers/macho_relocatable_file.cpp, line 1898.
collect2: error: ld returned 1 exit status
Comment 1 Jürgen Reuter 2017-09-24 18:16:31 UTC
Not sure whether this related to #82300, at first glance it looks different.
Comment 2 Eric Gallager 2017-09-24 18:27:24 UTC
(In reply to Jürgen Reuter from comment #1)
> Not sure whether this related to #82300, at first glance it looks different.

Yup, it's different from bug 82300; the one this one is actually a dup of is bug 82092 (they have the same linker error)

*** This bug has been marked as a duplicate of bug 82092 ***