Bug 81784 - [8 regression] gcc.dg/compare2.c fails starting with r250984
Summary: [8 regression] gcc.dg/compare2.c fails starting with r250984
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: testsuite (show other bugs)
Version: 8.0
: P3 normal
Target Milestone: 8.0
Assignee: Marek Polacek
URL:
Keywords:
: 81792 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-09 15:48 UTC by seurer
Modified: 2017-09-13 16:48 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2017-08-09 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description seurer 2017-08-09 15:48:21 UTC
The recent change to the test case gcc.dg/compare2.c doesn't seem to work quite right.  At least not on powerpc64 where it fails on both BE and LE (tested on power8).

spawn -ignore SIGHUP /home/seurer/gcc/build/gcc-trunk/gcc/xgcc -B/home/seurer/gcc/build/gcc-trunk/gcc/ /home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c -fno-diagnostics-show-caret -fdiagnostics-color=never -Wsign-compare -S -o compare2.s
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c: In function 'f':
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c:21:5: warning: comparison of integer expressions of different signedness: 'unsigned int' and 'int' [-Wsign-compare]
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c:25:5: warning: comparison of integer expressions of different signedness: 'unsigned int' and 'int' [-Wsign-compare]
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c:37:5: warning: comparison of integer expressions of different signedness: 'unsigned int' and 'int' [-Wsign-compare]
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c:41:5: warning: comparison of integer expressions of different signedness: 'unsigned int' and 'int' [-Wsign-compare]
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c:49:12: warning: operand of ?: changes signedness from 'int' to 'unsigned int' due to unsignedness of other operand [-Wsign-compare]
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c:57:12: warning: operand of ?: changes signedness from 'int' to 'unsigned int' due to unsignedness of other operand [-Wsign-compare]
output is:
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c: In function 'f':
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c:21:5: warning: comparison of integer expressions of different signedness: 'unsigned int' and 'int' [-Wsign-compare]
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c:25:5: warning: comparison of integer expressions of different signedness: 'unsigned int' and 'int' [-Wsign-compare]
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c:37:5: warning: comparison of integer expressions of different signedness: 'unsigned int' and 'int' [-Wsign-compare]
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c:41:5: warning: comparison of integer expressions of different signedness: 'unsigned int' and 'int' [-Wsign-compare]
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c:49:12: warning: operand of ?: changes signedness from 'int' to 'unsigned int' due to unsignedness of other operand [-Wsign-compare]
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c:57:12: warning: operand of ?: changes signedness from 'int' to 'unsigned int' due to unsignedness of other operand [-Wsign-compare]

PASS: gcc.dg/compare2.c case 1 (test for bogus messages, line 12)
PASS: gcc.dg/compare2.c case 2 (test for bogus messages, line 13)
PASS: gcc.dg/compare2.c case 3 (test for bogus messages, line 16)
PASS: gcc.dg/compare2.c case 4 (test for bogus messages, line 17)
PASS: gcc.dg/compare2.c case 5 (test for bogus messages, line 20)
PASS: gcc.dg/compare2.c case 6 (test for warnings, line 21)
PASS: gcc.dg/compare2.c case 7 (test for bogus messages, line 24)
PASS: gcc.dg/compare2.c case 8 (test for warnings, line 25)
PASS: gcc.dg/compare2.c case 9 (test for bogus messages, line 28)
PASS: gcc.dg/compare2.c case 10 (test for bogus messages, line 29)
PASS: gcc.dg/compare2.c case 11 (test for bogus messages, line 32)
PASS: gcc.dg/compare2.c case 12 (test for bogus messages, line 33)
PASS: gcc.dg/compare2.c case 13 (test for bogus messages, line 36)
PASS: gcc.dg/compare2.c case 14 (test for warnings, line 37)
PASS: gcc.dg/compare2.c case 15 (test for bogus messages, line 40)
PASS: gcc.dg/compare2.c case 16 (test for warnings, line 41)
PASS: gcc.dg/compare2.c case 17 (test for bogus messages, line 44)
PASS: gcc.dg/compare2.c case 18 (test for bogus messages, line 45)
PASS: gcc.dg/compare2.c case 19 (test for bogus messages, line 48)
FAIL: gcc.dg/compare2.c case 20 (test for warnings, line 49)
PASS: gcc.dg/compare2.c case 21 (test for bogus messages, line 52)
PASS: gcc.dg/compare2.c case 22 (test for bogus messages, line 53)
PASS: gcc.dg/compare2.c case 23 (test for bogus messages, line 56)
FAIL: gcc.dg/compare2.c case 24 (test for warnings, line 57)
FAIL: gcc.dg/compare2.c (test for excess errors)
Excess errors:
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c:49:12: warning: operand of ?: changes signedness from 'int' to 'unsigned int' due to unsignedness of other operand [-Wsign-compare]
/home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/compare2.c:57:12: warning: operand of ?: changes signedness from 'int' to 'unsigned int' due to unsignedness of other operand [-Wsign-compare]

testcase /home/seurer/gcc/gcc-trunk/gcc/testsuite/gcc.dg/dg.exp completed in 0 seconds

		=== gcc Summary ===

# of expected passes		22
# of unexpected failures	3
Comment 1 Andrew Pinski 2017-08-10 01:35:34 UTC
Confirmed on aarch64-linux-gnu.
Comment 2 Marek Polacek 2017-08-10 08:54:37 UTC
Author: mpolacek
Date: Thu Aug 10 08:54:04 2017
New Revision: 251021

URL: https://gcc.gnu.org/viewcvs?rev=251021&root=gcc&view=rev
Log:
	PR testsuite/81784
	* gcc.dg/compare2.c: Update dg-bogus and dg-warning.

Modified:
    trunk/gcc/testsuite/ChangeLog
    trunk/gcc/testsuite/gcc.dg/compare2.c
Comment 3 Marek Polacek 2017-08-10 08:55:11 UTC
Fixed.
Comment 4 Marek Polacek 2017-08-10 11:22:29 UTC
*** Bug 81792 has been marked as a duplicate of this bug. ***
Comment 5 Aldy Hernandez 2017-09-13 16:48:26 UTC
Author: aldyh
Date: Wed Sep 13 16:47:52 2017
New Revision: 252380

URL: https://gcc.gnu.org/viewcvs?rev=252380&root=gcc&view=rev
Log:
	PR testsuite/81784
	* gcc.dg/compare2.c: Update dg-bogus and dg-warning.

Modified:
    branches/range-gen2/gcc/testsuite/ChangeLog
    branches/range-gen2/gcc/testsuite/gcc.dg/compare2.c