Bug 8146 - [mainline regression] gcc 3.2 miscompiles gcc 2.95.3
Summary: [mainline regression] gcc 3.2 miscompiles gcc 2.95.3
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 3.2
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: wrong-code
Depends on:
Blocks:
 
Reported: 2002-10-04 10:46 UTC by prj
Modified: 2003-07-25 17:33 UTC (History)
5 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description prj 2002-10-04 10:46:00 UTC
 If I start with gcc 3.2 and try to bootstrap gcc 2.95.3, I get
 a bootstrap comparison failure.  The documentation says that this
 usually indicates that the host compiler (gcc 3.2 here) miscompiled
 gcc (2.95.3).
 Bootstrap comparison failure!
 cccp.o differs
 f/data.o differs
 f/target.o differs
 make[1]: *** [compare-lean] Error 1
 3.1 and 3.1.1 also fail to bootstrap 2.95.3.  IIRC, 3.1 had
 differences only in cccp.o.
 I suggest adding bootstrapping old versions to the pre-release
 testing procedure.  Having a buggy compiler is bad; having one
 that is buggy in such a way as to complicate downgrading to a
 not-known-to-me-to-be-buggy version is worse.
 (I was able to downgrade by doing "make install" after the failing
 "make bootstrap", and then using that incomplete 2.95.3 to do a
 successful bootstrap of a new 2.95.3.)

Release:
3.2

Environment:
System: Linux multivac.cwru.edu 2.4.19 #1 SMP Mon Aug 5 11:15:13 EDT 2002 i686 unknown
Architecture: i686

 
host: i686-pc-linux-gnu
build: i686-pc-linux-gnu
target: i686-pc-linux-gnu
configured with: ../gcc-3.2/configure --prefix=/package/host/localhost/gcc-3.2 --with-as=/package/host/localhost/gcc-3.2/conf/as --with-ld=/package/host/localhost/gcc-3.2/conf/ld --enable-threads --enable-libgcj --disable-nls
glibc 2.2.5
binutils 2.13

How-To-Repeat:
 Build 2.95.3 using 3.2.  I think you already have the relevant
 source files. :)  Files from my build or installation
 directories of 3.2 or 2.95.3 are available on request.
Comment 1 janis187 2002-10-23 16:38:23 UTC
From: Janis Johnson <janis187@us.ibm.com>
To: gcc-gnats@gcc.gnu.org, gcc-prs@gcc.gnu.org, gcc-bugs@gcc.gnu.org,
   nobody@gcc.gnu.org, prj@po.cwru.edu
Cc:  
Subject: Re: bootstrap/8146: gcc 3.2 miscompiles gcc 2.95.3
Date: Wed, 23 Oct 2002 16:38:23 -0700

 I tried this (bootstrapping GCC 2.95.3) with 3.2 that I built from a
 release tarball and with the 3.2 branch updated an hour or so ago, and
 with both of them I get the same bootstrap comparison failures that
 were reported in the PR:
 
   Bootstrap comparison failure!
   cccp.o differs
   f/data.o differs
   f/target.o differs
 
 This was on i686-pc-linux-gnu, with an old Caldera distribution plus
 binutils 2.12.1.
 
 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit-trail&database=gcc&pr=8146
 
 
 

Comment 2 Joe Buck 2002-10-31 14:13:52 UTC
From: Joe Buck <jbuck@synopsys.com>
To: gcc-gnats@gcc.gnu.org, gcc-bugs@gcc.gnu.org, prj@po.cwru.edu
Cc:  
Subject: Re: bootstrap/8146: gcc 3.2 miscompiles gcc 2.95.3
Date: Thu, 31 Oct 2002 14:13:52 -0800

 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit-trail&database=gcc&pr=8146
 
 I'm marking this as high priority, even though it's not certain that 
 this is a
 3.2 bug; it could be a 2.95.3 bug.  At least, it should be investigated 
 in more
 detail.
 

Comment 3 Joe Buck 2002-11-08 13:54:38 UTC
From: Joe Buck <jbuck@synopsys.com>
To: gcc-gnats@gcc.gnu.org, gcc-bugs@gcc.gnu.org, prj@po.cwru.edu
Cc:  
Subject: Re: bootstrap/8146: gcc 3.2 miscompiles gcc 2.95.3
Date: Fri, 08 Nov 2002 13:54:38 -0800

 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit-trail&database=gcc&pr=8146
 
 This is fixed on the branch by HJ's patch:
 
 2002-11-07  H.J. Lu <hjl@gnu.org>
 
          Fix bootstrap/8146 and
          gcc.c-torture/execute/20020307-2.c with -march=i686.
 
          * calls.c (PUSH_ARGS_REVERSED): Define only if not defined.
          * expr.c (PUSH_ARGS_REVERSED): Likewise.
 
          * config/i386/i386.h (PUSH_ARGS_REVERSED): Set to 1.
 
 Does this bug affect the mainline?
 

Comment 4 Joe Buck 2002-11-08 17:04:38 UTC
From: Joe Buck <jbuck@synopsys.com>
To: gcc-gnats@gcc.gnu.org, gcc-bugs@gcc.gnu.org, hjl@gnu.org, prj@po.cwru.edu
Cc:  
Subject: Re: bootstrap/8146: gcc 3.2 miscompiles gcc 2.95.3
Date: Fri, 08 Nov 2002 17:04:38 -0800

 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit-trail&database=gcc&pr=8146
 
 This PR is now fixed on the branch, but not in the mainline; I have just 
 verified
 that we still get the same failure.
 
 Should HJ's patch be applied to the mainline as well?
 
 I will be taking this PR as [mainline regression] now.
 
Comment 5 Volker Reichelt 2002-11-14 01:37:56 UTC
State-Changed-From-To: open->closed
State-Changed-Why: Now fixed on branch and mainline according to Eric Botcazou:
    
    > I verified yesterday: both gcc 3.2.1-pre and gcc 3.3-exp are now able to 
    > bootstrap gcc 2.95.3 (c,c++,objc,f77) on i686.
Comment 6 Richard Henderson 2002-12-11 15:36:00 UTC
From: Richard Henderson <rth@redhat.com>
To: Joe Buck <jbuck@synopsys.com>
Cc: gcc-gnats@gcc.gnu.org, gcc-bugs@gcc.gnu.org, hjl@gnu.org, prj@po.cwru.edu
Subject: Re: bootstrap/8146: gcc 3.2 miscompiles gcc 2.95.3
Date: Wed, 11 Dec 2002 15:36:00 -0800

 On Fri, Nov 08, 2002 at 05:04:38PM -0800, Joe Buck wrote:
 > This PR is now fixed on the branch, but not in the mainline; I have just 
 > verified
 > that we still get the same failure.
 > 
 > Should HJ's patch be applied to the mainline as well?
 
 No.  A different patch was intended to fix this problem on
 mainline.
 
 
 r~