Bug 79778 - [7 regression] missed optimization causes linux kernel build failure since r245135
Summary: [7 regression] missed optimization causes linux kernel build failure since r2...
Status: RESOLVED DUPLICATE of bug 72785
Alias: None
Product: gcc
Classification: Unclassified
Component: tree-optimization (show other bugs)
Version: 7.0.1
: P3 normal
Target Milestone: 7.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on: 72785
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-01 12:45 UTC by Arnd Bergmann
Modified: 2017-03-01 13:29 UTC (History)
1 user (show)

See Also:
Host:
Target: x86
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arnd Bergmann 2017-03-01 12:45:55 UTC
With the latest gcc-7.0.1 snapshot, I got lots of these failures building random linux kernel configurations:

kernel/built-in.o: In function `update_wall_time':
(.text+0x418a0): undefined reference to `____ilog2_NaN'

Variations of this symptom have happened in the past, e.g. pr36359, pr78653, pr78879, pr49642, pr72785, but for all I can tell, this one is slightly different again.

I have bisected the problem to r245135, and have confirmed that reverting this on top of r245806 (today's HEAD commit) fixes the problem for builds that ran into this on my test box.
Comment 1 Richard Biener 2017-03-01 12:47:47 UTC
Dup of PR72785?
Comment 2 Arnd Bergmann 2017-03-01 13:03:42 UTC
(In reply to Richard Biener from comment #1)
> Dup of PR72785?

I thought we had worked around PR72785 in the kernel, and I had not run into that problem until updating my gcc-7.0.1 snapshot yesterday. r245135, which introduces the problem for me came after the last comment on PR72785.
Comment 3 Markus Trippelsdorf 2017-03-01 13:29:13 UTC
It is a dup. See https://www.mail-archive.com/linux-kernel@vger.kernel.org/msg1340546.html

*** This bug has been marked as a duplicate of bug 72785 ***