Bug 7803 - Please submit a full bug report
Summary: Please submit a full bug report
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.2
: P3 normal
Target Milestone: ---
Assignee: Gabriel Dos Reis
URL:
Keywords: ice-on-invalid-code
Depends on:
Blocks:
 
Reported: 2002-09-01 20:06 UTC by carlo
Modified: 2012-10-26 15:06 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description carlo 2002-09-01 20:06:00 UTC
> g++-3.2 troep.cc
troep.cc:4: `template<class _Alloc> class std::allocator' as declarator
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.

> cat troep.cc
#include <memory>
#include <iostream>

std::allocator allocator;

int main(void)
{
  std::cout << sizeof(allocator) << std::endl;
  return 0;
}

Release:
3.2

Environment:
i686-gnu-linux
Comment 1 Nathan Sidwell 2002-09-13 13:37:26 UTC
State-Changed-From-To: open->analyzed
State-Changed-Why: confirmed as a regression
Comment 2 pop 2002-10-09 00:34:55 UTC
From: =?iso-8859-1?Q?Pop_S=E9bastian?= <pop@gauvain.u-strasbg.fr>
To: nathan@gcc.gnu.org, carlo@alinoe.com, gcc-bugs@gcc.gnu.org,
	gcc-prs@gcc.gnu.org, nobody@gcc.gnu.org, gcc-gnats@gcc.gnu.org
Cc:  
Subject: Re: c++/7803: Please submit a full bug report
Date: Wed, 9 Oct 2002 00:34:55 +0200

 This PR is a duplicate of PR#7721 that provides a simpler bug example.
 see http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit-trail&database=gcc&pr=7721
 
Comment 3 Gabriel Dos Reis 2002-10-11 11:29:58 UTC
Responsible-Changed-From-To: unassigned->gdr
Responsible-Changed-Why: Worked on it
Comment 4 Gabriel Dos Reis 2002-10-11 11:29:58 UTC
State-Changed-From-To: analyzed->closed
State-Changed-Why: http://gcc.gnu.org/ml/gcc-patches/2002-10/msg00505.html