User account creation filtered due to spam.

Bug 7376 - linux kernel 2.4.19-rc3 parser error w/ 3.2 CVS (works w/ 3.1) on ix86 semaphore.c
Summary: linux kernel 2.4.19-rc3 parser error w/ 3.2 CVS (works w/ 3.1) on ix86 semaph...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 3.2
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-07-22 11:36 UTC by priestwilliaml
Modified: 2003-07-25 17:33 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
semaphore.i (50.48 KB, text/x-c)
2003-05-21 15:16 UTC, priestwilliaml
Details

Note You need to log in before you can comment on or make changes to this bug.
Description priestwilliaml 2002-07-22 11:36:01 UTC
Trying to compile/build Linux Kernel 2.4.19-rc3 on ix86 using
latest bootstrapped 3.2 sync'ed from CVS today (didn't work
with sync from last week either).  File in question is
semaphore.c.  This same file compiles fine w/ 3.1.
./configure --enable-languages="c,c++" \ --prefix=/home/bpriest/usr/local
make bootstrap-lean

/home/bpriest/usr/local/bin/gcc --verbose --save-temps -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -mpreferred-stack-boundary=2 -march=i686   -nostdinc -I /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.1/include -DKBUILD_BASENAME=semaphore  -c -o semaphore.o semaphore.c
Reading specs from /home/bpriest/usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.2/specs
Configured with: ../gcc/configure --enable-languages=c,c++ --prefix=/home/bpriest/usr/local : (reconfigured) ../gcc/configure --enable-languages=c,c++ : (reconfigured) ../gcc/configure --enable-languages=c,c++ --prefix=/home/bpriest/usr/local
Thread model: single
gcc version 3.2 20020722 (experimental)
 /home/bpriest/usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.2/cc1 -E -quiet -nostdinc -v -I/usr/src/linux/include -I /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.1/include -D__GNUC__=3 -D__GNUC_MINOR__=2 -D__GNUC_PATCHLEVEL__=0 -D__KERNEL__ -DKBUILD_BASENAME=semaphore semaphore.c -Wall -Wstrict-prototypes -Wno-trigraphs -mpreferred-stack-boundary=2 -march=i686 -fno-strict-aliasing -fno-common -fomit-frame-pointer -O2 semaphore.i
#include "..." search starts here:
#include <...> search starts here:
 /usr/src/linux/include
 /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.1/include
End of search list.
semaphore.c:265:1: missing terminating " character
semaphore.c:290:1: missing terminating " character

same file compiled w/ 3.1
/usr/local/bin/gcc --verbose --save-temps -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -mpreferred-stack-boundary=2 -march=i686   -nostdinc -I /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.1/include -DKBUILD_BASENAME=semaphore  -c -o semaphore.o semaphore.c
Reading specs from /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.1/specs
Configured with: ../gcc-3.1/configure --prefix=/usr/local --enable-languages=c,c++,g77
Thread model: single
gcc version 3.1
 /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.1/cpp0 -lang-c -nostdinc -v -I/usr/src/linux/include -I /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.1/include -D__GNUC__=3 -D__GNUC_MINOR__=1 -D__GNUC_PATCHLEVEL__=0 -D__ELF__ -Dunix -D__gnu_linux__ -Dlinux -D__ELF__ -D__unix__ -D__gnu_linux__ -D__linux__ -D__unix -D__linux -Asystem=posix -D__OPTIMIZE__ -D__STDC_HOSTED__=1 -Acpu=i386 -Amachine=i386 -Di386 -D__i386 -D__i386__ -D__i686 -D__i686__ -D__pentiumpro -D__pentiumpro__ -D__tune_i686__ -D__tune_pentiumpro__ -D__KERNEL__ -DKBUILD_BASENAME=semaphore semaphore.c -Wall -Wstrict-prototypes -Wno-trigraphs semaphore.i
GNU CPP version 3.1 (cpplib) (i386 Linux/ELF)
#include "..." search starts here:
#include <...> search starts here:
 /usr/src/linux/include
 /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.1/include
End of search list.
semaphore.c:265:1: warning: multi-line string literals are deprecated
semaphore.c:269:35: warning: multi-line string literals are deprecated
semaphore.c:271:27: warning: multi-line string literals are deprecated
semaphore.c:274:35: warning: multi-line string literals are deprecated
 /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.1/cc1 -fpreprocessed semaphore.i -quiet -dumpbase semaphore.c -mpreferred-stack-boundary=2 -march=i686 -O2 -Wall -Wstrict-prototypes -Wno-trigraphs -version -fno-strict-aliasing -fno-common -fomit-frame-pointer -o semaphore.s
GNU CPP version 3.1 (cpplib) (i386 Linux/ELF)
GNU C version 3.1 (i686-pc-linux-gnu)
	compiled by GNU C version 3.1.
semaphore.c:265:1: warning: multi-line string literals are deprecated
semaphore.c:269:36: warning: multi-line string literals are deprecated
semaphore.c:271:23: warning: multi-line string literals are deprecated
semaphore.c:274:36: warning: multi-line string literals are deprecated
 /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.1/../../../../i686-pc-linux-gnu/bin/as --traditional-format -V -Qy -o semaphore.o semaphore.s
GNU assembler version 2.12.1 (i686-pc-linux-gnu) using BFD version 2.12.1

I attached the 3.2 .i file (but since this is where the
problem is I'm not sure it will help).  I can also provide
the 3.1 .i file if that would be helpful.

Release:
3.2 CVS sync'ed today (7/22/02 CST)

Environment:
linux ix86
Comment 1 Neil Booth 2002-07-22 13:10:45 UTC
State-Changed-From-To: open->closed
State-Changed-Why: Not a bug.  Like 3.1 complains, the code needs to be fixed.
Comment 2 Andrew Pinski 2002-07-22 14:59:54 UTC
From: Andrew Pinski <pinskia@physics.uc.edu>
To: priestwilliaml@yahoo.com
Cc: gcc-gnats@gcc.gnu.org
Subject: Re: c/7376: linux kernel 2.4.19-rc3 parser error w/ 3.2 CVS (works w/ 3.1) on ix86 semaphore.c
Date: Mon, 22 Jul 2002 14:59:54 -0400

 This is NOT a gcc 3.2 problem, gcc 3.2 removes the ability to 
 have multi-line string literals.
 This is a linux kernel problem with their source code, the 
 warning in 3.1 is so they
 would change the code to be fixed.
 
 Fix the code and try again or try a newer version of the linux 
 kernel (or file a bug with Linus).
 
 
 Thanks,
 Andrew Pinski
 
 
 PS can some one close this bug report because the reasons above.