Bug 71809 - compile llvm3.8.0 failed by the libstdc++ of gcc6.1.0
Summary: compile llvm3.8.0 failed by the libstdc++ of gcc6.1.0
Status: RESOLVED INVALID
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 6.1.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-08 03:40 UTC by sulit
Modified: 2017-01-07 23:27 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
compile and build log file (22.09 KB, text/plain)
2016-07-08 03:40 UTC, sulit
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sulit 2016-07-08 03:40:01 UTC
Created attachment 38861 [details]
compile and build log file

I compile llvm3.8.0  by libstdc++ of gcc6.1.0, and get the error, I suspect this is a bug, but don't make sure that. The error as flow:

/usr/bin/../lib/gcc/x86_64-isoft-linux/6.1.0/../../../../include/c++/6.1.0/tuple:1381:14: error: no matching constructor for initialization of 'tuple<llvm::LexicalScope *&&, const llvm::DILocalScope *&&, nullptr_t &&, bool &&>'
    { return tuple<_Elements&&...>(std::forward<_Elements>(__args)...); }
             ^                     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Comment 1 Andrew Pinski 2016-07-08 04:01:14 UTC
https://bugzilla.suse.com/show_bug.cgi?id=964143
Comment 3 Richard Biener 2016-07-08 08:29:09 UTC
clang bug
Comment 4 sulit 2016-07-08 09:59:13 UTC
ok
Comment 5 Jeffrey Walton 2017-01-07 20:36:57 UTC
(In reply to sulit from comment #4)
> ok

Sulit, I'm seeing the issue under Clang 3.5 on Ubuntu 16. Do you have a LLVM bug report for this issue?
Comment 6 Jeffrey Walton 2017-01-07 23:27:51 UTC
(In reply to Jeffrey Walton from comment #5)
> (In reply to sulit from comment #4)
> > ok
> 
> Sulit, I'm seeing the issue under Clang 3.5 on Ubuntu 16. Do you have a LLVM
> bug report for this issue?

Here's a Ubuntu bug report for the issue: https://bugs.launchpad.net/ubuntu/+bug/1654795.